Closed Bug 1571685 Opened 3 years ago Closed 2 years ago

The "Dismiss" button from the "Special Monitor" snippet is not visible if the system's "High Contrast" mode is enabled

Categories

(Firefox :: Messaging System, defect, P3)

All
Windows
defect

Tracking

()

VERIFIED FIXED
Firefox 79
Tracking Status
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox79 --- verified

People

(Reporter: mcoman, Assigned: emcminn)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image rec of the issue.gif

[Affected versions]:

  • Firefox Release 68.0.1 - Build ID: 20190717172542
  • Firefox Beta 69.0b10 - Build ID: 20190801185445
  • Firefox Nightly 70.0a1 - Build ID: 20190805220030

[Affected Platforms]:

  • All Windows

[Prerequisites]:

  • Have a new Firefox profile with the "browser.newtabpage.activity-stream.asrouter.devtoolsEnabled" pref's value set to "true" in the "about:config" page;
  • Have the "High Contrast" mode enabled.

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Navigate to "about:newtab#asrouter" and select the "snippets_local_testing" option from the "Messages" dropdown menu.
  3. Scroll to the bottom of the page and click the "Show" button from the "SPECIAL_SNIPPET_BUTTON_1" section.
  4. Click the "Collapse devtools" button from the top-right part of the page.
  5. Observe the "Special Monitor" snippet's elements.

[Expected result]:

  • All the snippet's elements are correctly rendered and visible.

[Actual result]:

  • The "Dismiss" button is not visible at all.

[Notes]:

  • This issue is reproducible with all the snippets.
  • Attached a screen recording of the issue.
Assignee: nobody → emcminn

Setting this to p2 since this is an existing issue and not a regression caused by the new feature

Priority: -- → P2
Priority: P2 → P3

Sounds like we aren't able to detect high-contrast mode. We might get some recommendations from the accessibility team on that.

Blocks: 1644230
Pushed by emcminn@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7ea1586e531e
Set fill color and inheritance on Snippet block button to be compatible with Windows High Contrast mode r=Gijs
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (79.0a1 Build ID - 20200622093309) installed, on Windows 10 x64. Now, the "Dismiss" button from the "Special Monitor" snippet is visible if the system's "High Contrast" mode is enabled.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.