Closed Bug 1571744 Opened 4 months ago Closed 4 months ago

Create a `CustomDistributionMetricType`

Categories

(Data Platform and Tools :: Glean: SDK, task, P3)

task

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Dexter, Assigned: mdroettboom)

References

(Blocks 1 open bug)

Details

(Whiteboard: [telemetry:glean-rs:m7][geckoview])

Attachments

(3 files)

Some GeckoView histograms require a fairly custom shape of the distribution, which doesn't directly fit into the concept of "infinite binning". Additionally, some distributions do not have units or have custom units (e.g. "pixels" or "% of vsync").

We should introduce a new metric type, only usable for mapping to Gecko histograms, which allows for specifying:

  • either linear or exponential bucketing;
  • min/max range;
  • time_unit (only in the metrics.yaml, for metadata)
  • number of buckets.
Blocks: 1566340
Priority: -- → P3
Whiteboard: [telemetry:glean-rs:m7][geckoview]
Duplicate of this bug: 1571743
Assignee: nobody → mdroettboom
Attached file GitHub Pull Request
Attached file GitHub Pull Request
Attached file GitHub Pull Request
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.