Closed Bug 1571838 Opened 8 months ago Closed 7 months ago

Invalid Canvas rendering with Hardware acceleration disabled

Categories

(Core :: Canvas: WebGL, defect, P1)

69 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: max.vlasov, Assigned: jgilbert)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

Using third party code (javascript + css) to render flipping book effect with pdf files
The demo showing reproducible results is at the following URL :
http://preview.codecanyon.net/item/real3d-flipbook-wordpress-plugin/full_screen_preview/6942587
( top webgl "shelf")
Hardware acceleration is off

Actual results:

No listing pages are shown.
If I switch hardware acceleration to on, then the pages are visible again
Reproducible with Firefox Developer Edition 69.0b10 (64-bit) on two different machines

Expected results:

The pages should appear
This plugin worked correctly with HW of on Firefox for the latest couple of years with HW Off.
Firefox Release 68 works correctly with both HW settings

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=eea7be13a02925e164a7ad39d376a82ae6743d90&tochange=a6f3fd30a0a712f426a36bdb01bb40c56b6d8334

Regressed by:
a6f3fd30a0a712f426a36bdb01bb40c56b6d8334 Jeff Gilbert — Bug 1443181 - If ANGLE D3D11 disabled, ask for D3D9 explicitly. r=lsalzman

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Canvas: WebGL
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Regressed by: 1443181

Jeff,
Your patch of Bug 1443181 seems to cause the regression. Can you please look into this?

Flags: needinfo?(jgilbert)

We should be using WARP in this case, which is D3D11.

Flags: needinfo?(jgilbert)
Priority: -- → P1
Duplicate of this bug: 1569976
Assignee: nobody → jgilbert

Please attach a copy of your about:support Graphics section.

Flags: needinfo?(max.vlasov)
Flags: needinfo?(alice0775)
Attached file about:support
Flags: needinfo?(alice0775)

Yeah, ok, this is a bigger problem than bug 1443181 fixes.

Let's backout bug 1443181. (unfortunately I'm on out through next Tuesday)

jbonisteel, can you assign this?
ryanvm, can we possibly back 1443181 out of 69 as well?

Flags: needinfo?(ryanvm)
Flags: needinfo?(max.vlasov)
Flags: needinfo?(jbonisteel)
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/975f26e0fff1
Backed out changeset a6f3fd30a0a7 (bug 1443181). r=jbonisteel

Comment on attachment 9087425 [details]
Bug 1571838 - Backed out changeset a6f3fd30a0a7 (bug 1443181). r?jbonisteel

Approved for 69.0b16 also.

Flags: needinfo?(ryanvm)
Flags: needinfo?(jbonisteel)
Attachment #9087425 - Flags: approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.