Address book entries imported from Netscape 4 are all marked 'plain text'

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: michael.graubart7, Assigned: racham)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061103

When a personal address book - in which entries do not have 'Prefers to receive
HTML' checked - is exported from Netscape 4.79 as 'Bookmarks.ldif' and imported
into Mozilla, the entries in the Mozilla address book end up marked 'Plain
text'.  They should end up marked 'Unknown'.

Reproducible: Didn't try
Steps to Reproduce:
1. Create personal address book in NS 4.79 in which the checkbox 'Prefers to
receive HTML' is NOT checked.  (I.e. preferences are unknown).
2. Export NS 4.79 personal address book.
3. Import it into Mozilla.
4. Examine individual cards.

Actual Results:  All such entries are marked 'plain text'.

Expected Results:  They should be marked 'Unknown'.

Classic theme.

Comment 1

17 years ago
Michael, the only two options are HTML or plain text. If the addressee prefers not to receive 
HTML, they'll receive plain text. There is no "unknown."

Does that make sense? Please let us know.
(Reporter)

Comment 2

17 years ago
No, I'm afraid it doesn't make sense. On each card of my personal address book
in Mozilla (all builds since v.1.1a that I have tried) there is the following:
'Prefers to receive messages formatted as:', and THREE options: 'Unknown',
'Plain text' and 'HTML' are provided in the little drop-down menu.  

In Netscape 4.79, there is just a checkbox: 'Prefers to receive HTML'.
Logically, therefore, if that is not checked it means that the recipient has NO
PREFERENCES.  That is the equivalent of 'Unknown' in Mozilla.  And that is how
it works out in practice: in my Netscape address book I have left all these
checkboxes unchecked, and so if I try to send a formatted message in Netscape 4,
I am asked what I want to do - convert to text, send as HTML or send as both.

When I imported my Netscape address book into Mozilla, however, all the imported
cards that originally had their checkboxes unchecked (i.e. had NO preferences)
said 'Prefers plain text' in the Mozilla address book, and as a consequence no
formatting was sent. I have now been right through my Mozilla address book and
changed all the ones that got imported from Netscape 4.79 as 'Plain text' into
'Unknown', and now Mozilla asks me what I want to do - convert to text, send as
HTML or send as both - every time I want to send a message that has formatting.
 That is exactly right. My point was just that because an unchecked textbox in
Netscape 4 means 'no preference' (logically, AND in terms of how Netscape
behaves), such cards should be imported into Mozilla as 'Unknown'.

In any case, 'Unknown' is the safer option, because then Mozilla asks one what
to do. So for that reason alone cards that in Netscape 4 do not explicitly say
'Plain text only' (which they can't, of course, since that option is not given
in Netscape 4), should be imported into Mozilla without an explicit preference,
i.e. as 'Unknown'.

I hope this makes sense.  It is all a quite minor matter, though it should be
mentioned under importing address books in the Mozilla 'Help' system if it can't
be fixed or you prefer to leave it as it is.
Mac classic builds are "dead"

You could try a 1.3.1 OS classic build from here :
http://wamcom.org/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.