Closed Bug 1572008 Opened 4 months ago Closed 4 months ago

Re-organize test folder

Categories

(DevTools :: Console, task, P2)

task

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Our test folder should look like what's shown in https://bugzilla.mozilla.org/show_bug.cgi?id=1564431#c17

Blocks: 1572667
  • mochitest folder is renamed browser.
  • unit folder is rename xpcshell.
  • all the file and folder for mocha are put in a node folder.

We take this as an opportunity to revist our stub-generating
mochitests.
Previously we had 2 tests for each kind of stubs, one for check,
the other one for updating.
It was not ideal when you wanted to update all the stubs at once
because you add either to mention every 5 files, or unskip the
update test files.
We now merge the update and the check files in a single test.
By default, the test that the stubs are up to date, and if you
pass the --setenv WEBCONSOLE_STUBS_UPDATE=true param, it will
update the stubs.
This allow us to move the function that actually generate the stub
in the test file, and have a helper file for multi-purpose functions.
Because these tests are failing on TRY, let's disabled them so we
can land the test re-organization (we'll re-enable them in Bug 1572667).

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62669fe12b1d
Re-organize WebConsole client tests folder. r=Honza.
Regressions: 1572778
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Assignee: nobody → nchevobbe
You need to log in before you can comment on or make changes to this bug.