Closed Bug 1572029 Opened 1 year ago Closed 1 year ago

Give the tracking protection toggler an accessible label

Categories

(Firefox :: Protections UI, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: MarcoZ, Assigned: MarcoZ)

Details

(Keywords: access, Whiteboard: [privacy-panel][skyline])

Attachments

(1 file)

STR, with NVDA:

  1. Go to any web site.
  2. Press CTRL+L to go to address bark then Shift+Tab to get to the tracking protection button.
  3. Press Space.
    • Focus lands on the "Site not working?" link.
  4. Press Tab.
    • Expected: NVDA should say something like "Disable tracking protections for <site name>" or similar, if this site is being protected by default.
    • Actual: NVDA only says "button", without indicating what the button does.

Patch coming up that will add a context-dependent screen reader accessible label to indicate whether a press of the button will disable or enable protections for the given host.

Priority: -- → P1
Whiteboard: [skyline] → [privacy-panel][skyline]
Pushed by mzehe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/04fb760be124
Give the tracking protection toggler an accessible label, r=johannh

Fixed the placeholders, %S instead of %s as in my original patch, and queued another landing.

Flags: needinfo?(mzehe)
Pushed by mzehe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/24f710e8951c
Give the tracking protection toggler an accessible label, r=johannh
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+

Hello!
Reproduced the issue with Firefox 70.0a1 (20190806214332) on Windows 10x64.
The issue is verified fixed with Firefox 70.0b9 (20190923154733) while using NVDA screen reader on Widows 10x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.