Closed Bug 1572235 Opened 11 months ago Closed 11 months ago

Spurious markers appear in profile

Categories

(Core :: Gecko Profiler, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: whawkins, Assigned: whawkins)

References

Details

Attachments

(1 file)

In certain cases, it is possible that markers generated just after a previous run of the profiler is completed instead appear in the profile generated by the subsequent run.

To reproduce:

  1. Run the profiler with a certain set of preference options that will generate a certain type of marker M under those conditions.

  2. Capture the profile and stop the profiler.

  3. Verify that the profile contains M-type markers.

  4. Change the options such that those M-type markers will not be generated and then restart the profiler.

  5. Capture the profile and stop the profiler.

  6. Verify in the UI that M-type markers are not there.

  7. Open the profile capture in a text editor.

  8. Note that the M-type markers are in the file (but usually the profile-start marker).

Patch coming to fix this problem.

Thanks for the bug and the incoming patch!
I'm moving this to the right component for Firefox Profiler. The component you used is more specific to the Devtools' performance panel (which uses the Firefox Profiler underneath :) ).

Component: Performance Tools (Profiler/Timeline) → Gecko Profiler
Product: DevTools → Core

I think I've seen Gerald or Greg mentioning this problem in the past, maybe there's an existing bug about this. Gerald would know probably.

Yes, I think bug 1529053 may be about the same issue. As per bug 1529053 comment 1, I'm hoping that bug 1562604 will just fix this -- but that is still some weeks away.

Will, if you have something ready, feel free to post it, thank you.

Type: defect → task
Priority: -- → P3
See Also: → 1529053

Thanks gerald. I looked at bug 1529053 and I believe that they are the same issue. This is not a comprehensive solution (like the one proposed in bug 1562604) but seems to do the job. I say seems because the issue was hard to discover and hard(ish) to reproduce. However, with this patch in place, the problem seems to go away.

I passed an initial sniff test from others familiar with the profiler and I look forward to hearing what you think about the patch.

Thanks to you both (julienw and gerald) for the help!
Will

Yeah, that seems like it will work. It doesn't perform the final collection, but at least we don't get old stale markers.

Looks like our try jobs all passed.

Keywords: checkin-needed

Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c9c7f28c2393
Expose a method to remove markers leftover from previous runs of the profiler. r=gerald

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.