Closed Bug 1572336 Opened 2 months ago Closed 2 months ago

Merge marionette.js into all.js

Categories

(Core :: Preferences: Backend, task)

task
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: njn, Assigned: njn)

References

Details

Attachments

(1 file)

There's no good reason for this file to be separate from all.js, and the separation has caused confusion in the past (see bug 1554690).

Blocks: 1572331
No longer depends on: 1572332
Duplicate of this bug: 1554690

Depends on D41145

Pushed by nnethercote@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5995a967c99b
Merge marionette.js into all.js. r=ato

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/aa7d58ca2f4b
Port bug 1572336 - Merge marionette.js prefs into all-thunderbird.js. rs=bustage-fix

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Rob, Samuel: can't you please check whether my bustage fix is right. Of course the file needed to be removed from package-manifest.in but I'm not sure we need those prefs. I guess we do.

Flags: needinfo?(samuel.thibault)
Flags: needinfo?(rob)

My understanding is that Thunderbird uses all.js, and then overrides some prefs in thunderbird-all.js. So I don't think the additions to thunderbird-all.js are necessary; you've effectively just defined them twice.

Damn, I didn't look properly, they went into modules/libpref/init/all.js, not browser/app/profile/firefox.js. Sigh, I'll pull them out again.

Flags: needinfo?(samuel.thibault)
Flags: needinfo?(rob)
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/089cade441b7
Port bug 1572336 - Remove marionette prefs from all-thunderbird.js since they are in modules/libpref/init/all.js. rs=bustage-fix DONTBUILD
You need to log in before you can comment on or make changes to this bug.