Closed Bug 1572475 Opened Last month Closed Last month

The Sidebar expands when a long username or website are saved

Categories

(Toolkit :: Password Manager, defect, P2)

70 Branch
Desktop
All
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified

People

(Reporter: carmenf, Assigned: ntim)

References

(Blocks 1 open bug)

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(3 files)

Attached image sidebar expands.gif

[Affected Versions]:

  • Nightly 70.0a1 (Build ID: 20190808093310)

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

  • Have a Firefox profile with at least one saved login.

[Steps to reproduce]:

  1. Open the latest Nightly browser and navigate to "about:logins" page.
  2. Select a saved login and click the "Edit" button.
  3. Edit the username so that you have at least 50 characters.
  4. Click the “Save Changes” button.
  5. Observe the way the Sidebar behaves.

[Expected results]:

  • The width of the Sidebar remains the same.

[Actual results]:

  • The width of the Sidebar expands.

[Notes]:

  • The Sidebar is displayed as expanded also when navigating to the “about:logins” page when there are no logins saved at all. This is because the text is displayed on 2 different rows instead of 3, as per the UI specifications.
  • The Sidebar also resizes when searching for logins, depending on the usernames’ number of characters.
  • Attached a screen recording with the issue.

Would be good to overflow or ellipsize non-wrapping strings in the sidebar.
Ryan, do you have a preference for how we should handle cases like this - bearing in mind usernames might be account numbers or other long, non-wrapping strings?

Flags: needinfo?(rgaddis)
Priority: -- → P2

Let's maintain a fixed width of the list at 320px and ellipsize when needed. Screenshot attached.

Flags: needinfo?(rgaddis)
Attached image overflow
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f7db69e3462c
Make the about:logins sidebar have a fixed width. r=MattN
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

I have verified this issue on the latest Nightly 70.0a1 build (2019-08-16) (64 bit) on Windows 10 x64, Mac 10.14 and Arch Linux.

  • The width of the sidebar is now fixed and doesn't expand any more when long usernames/websites are saved.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Keywords: regression

I noticed that the sidebar still expands when there are 0 logins. Does this need to be a new issue?

Flags: needinfo?(ntim.bugs)

(In reply to rgaddis from comment #9)

I noticed that the sidebar still expands when there are 0 logins.

I can't reproduce this. Do you have a screenshot from the latest Nightly or some steps to reproduce ?

Does this need to be a new issue?

Yep, if you can still reproduce, thanks!

Flags: needinfo?(ntim.bugs) → needinfo?(rgaddis)

While I was able to get the sidebar to grow yesterday with 0 logins, I retried today with the latest build and was unable to reproduce... so... nevermind!

Thanks Tim.

Flags: needinfo?(rgaddis)
You need to log in before you can comment on or make changes to this bug.