Closed Bug 1572478 Opened 5 months ago Closed 5 months ago

The master password should not be requested more times in a row

Categories

(Firefox :: about:logins, enhancement, P2)

Desktop
All
enhancement

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: danibodea, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(1 file)

Note

  • When the user attempts to edit a login, the master password is requested too many times in a row.

Affected versions

  • Nightly v70.0a1

Affected platforms

  • All

Steps to reproduce

  1. Open browser.
  2. Save any login.
  3. Set a master password.
    (Restart browser.)
  4. Open the "about:logins" page.
    Observe: Master password is requested. Type it in.
  5. Click the "edit" button to edit a login.
  6. Click the "eye-like" icon to reveal the login password.
    Observe: Master password is requested. Type it in.
  7. Change anything to the saved login (Website Address/Username/Password).
  8. Click the "Save Changes" button.
    Observe: Master password is requested. Type it in.

Expected result

  • The master password is not requested so often.

Actual result

  • The Master Password is requested too often.

(In reply to Bodea Daniel [:danibodea] from comment #0)

  1. Click the "Save Changes" button.
    Observe: Master password is requested. Type it in.

You're saying the MP is requested as soon as Save is clicked? If so, that is definitely not intentional.

Blocks: 1567230
Priority: -- → P2
Whiteboard: [passwords:generation] [skyline] → [passwords:management] [skyline]

Yes, that does happen. The problem is that we don't have specification on the appearance of the master password prompt. Are there any written specification on the behavior of the MP? We could use then for test case writing around the password manager because I don't think it behaves correctly or as previously expected. Thanks.

Assignee: nobody → jaws
Status: NEW → ASSIGNED

We should only prompt for master password when copying a password, or when changing from a hidden to revealed password.

This patch maintains the revealed state when going from readonly to edit mode of the login. When leaving edit mode, whether through cancel or save, the revealed state is reset.

Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d01e6a3eea5c
Don't prompt for master password when re-rendering the login-item. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

I can confirm that the master password is not requested anymore when saving changes on a login.

Steps to reproduce:

  1. Open browser.
  2. Save any login.
  3. Set a master password.
    (Restart browser.)
  4. Open the "about:logins" page.
    Observe: Master password is requested. Type it in.
  5. Click the "edit" button to edit a login.
  6. Click the "eye-like" icon to reveal the login password.
    Observe: Master password is requested. Type it in.
  7. Change anything to the saved login (Website Address/Username/Password).
  8. Click the "Save Changes" button.

Before fix: Observe: Master password is requested. Type it in.
After fix: Master password is not requested when saving changes of a login.

Validated in Nighty v70.0a1 (2019-08-29) (64-bit) on Windows 10 and Mac OS 10.13.6.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.