Closed Bug 1572492 Opened 2 years ago Closed 2 years ago

[Protections Panel] Info message background and learn more link aren't correctly placed in RTL

Categories

(Firefox :: Site Identity, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: ehsan.akhgari, Assigned: andreio)

References

(Blocks 1 open bug)

Details

(Keywords: rtl, Whiteboard: [privacy-panel][skyline])

Attachments

(2 files)

Attached image panel-rtl.png

Please see the screenshot. The problems are:

  • The header image isn't mirrored.
  • The learn more button isn't mirrored.
Summary: The protection panel header is broken in RTL mode → [Protections Panel] Info message background and learn more link aren't correctly placed in RTL
Blocks: 1567522
Priority: -- → P1
Whiteboard: [privacy-panel][skyline]
Duplicate of this bug: 1573309

The first issue can be easily fixed, just change:
https://searchfox.org/mozilla-central/rev/ec806131cb7bcd1c26c254d25cd5ab8a61b2aeb6/browser/themes/shared/customizableui/panelUI.inc.css#1116
to float: inline-end.

The second issue could be a bit trickier, see bug 1539633. Mirroring this image will mirror also the shield icon.
Probably another SVG for RTL is needed here?
Or, simply mirror this one and in bug 1539633 make sure to mirror all the rest.

See Also: → 1539633
Assignee: nobody → andrei.br92

(In reply to Itiel from comment #2)

The second issue could be a bit trickier, see bug 1539633. Mirroring this image will mirror also the shield icon.
Probably another SVG for RTL is needed here?
Or, simply mirror this one and in bug 1539633 make sure to mirror all the rest.

After discussing this with design the decision was to not change the background positioning in RTL mode.

Status: NEW → ASSIGNED
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/76e4b9536c75
Protections Panel message learn more link is incorrectly placed in RTL r=nhnt11
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
See Also: → 1608192
You need to log in before you can comment on or make changes to this bug.