Closed Bug 1572504 Opened 1 year ago Closed 1 year ago

Use BytecodeLocation and BytecodeIterator in BytecodeAnalysis::init

Categories

(Core :: JavaScript Engine, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- fixed

People

(Reporter: asorholm, Assigned: asorholm)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Replace uses of jsbytecode* and pcOffset inside BytecodeAnalysis::init with BytecodeLocation and BytecodeIterator.

Blocks: 1478034
Assignee: nobody → asorholm
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3

Replacing uses of jsbytecode and pcToOffset with BytecodeLocation and BytecodeIterator

Priority: P3 → P1
Keywords: checkin-needed
Depends on: 1572870
Blocks: 1572870
No longer depends on: 1572870
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9262dd831ebd
Use BytecodeLocation and BytecodeIterator in BytecodeAnalysis::init. r=mgaudet
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

You need to log in before you can comment on or make changes to this bug.