Closed Bug 1572556 Opened 1 year ago Closed 1 year ago

pref for DS 69 mitigation strategy

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox69 + wontfix
firefox70 --- verified

People

(Reporter: thecount, Assigned: thecount)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(1 file, 1 obsolete file)

Right now we can turn on and off DS/Adzerk via a pref, but if one for whatever reason is an issue at launch and we need to pref it off, we lose both DS and Adzerk and end up revert to AS.

I think we should have optional values in our DS config pref for a basic hard coded layout, which is DS configured to look like the old experience.

The other thing is a similar option to turn off Adzerk without turning off DS.

This doesn't cover the case of turning off DS but leaving on Adzerk, that would be too complex.

[Tracking Requested - why for this release]:

Assignee: nobody → sdowne
Priority: -- → P1

I'm looking at it like this, we have two optional values in the pref that by default are not there, which look like this:

"hardcoded_basic_layout": true, "spocs_endpoint": "https://getpocket.cdn.mozilla.net/v3/firefox/unique-spocs"

You would add these props to the browser.newtabpage.activity-stream.discoverystream.config pref

The first one, "hardcoded_basic_layout": true sets the hard coded layout from our 7 row one to a 1 row one.

The second prop "spocs_endpoint": "https://getpocket.cdn.mozilla.net/v3/firefox/unique-spocs" allows you to override the spocs endpoint to a non Adzerk endpoint. It can technically be anything, but in the example above I used the one we've been using before Adzerk.

Neither of these changes should change the default pref, this are all optional changes and if omitted the experience should not use either of these new features.

Steps to test:

  1. Change browser.newtabpage.activity-stream.discoverystream.config to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","collapsible":true,"enabled":true,"show_spocs":true,"hardcoded_layout":true,"personalized":false,"layout_endpoint":"https://getpocket.cdn.mozilla.net/v3/newtab/layout?version=1&consumer_key=$apiKey&layout_variant=basic", "hardcoded_basic_layout": true, "spocs_endpoint": "https://getpocket.cdn.mozilla.net/v3/firefox/unique-spocs"}
  2. Load a new tab.

Ensure you only see 1 row of 3 cards in the layout, and the third card is sponsored.

Comment on attachment 9085285 [details]
Uplift 1572556 - Mitigation strategy for 69 DS and Adzerk

Beta/Release Uplift Approval Request

  • User impact if declined: Risk mitigation for a feature with revenue impact.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Steps to test:
  1. Change browser.newtabpage.activity-stream.discoverystream.config to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","collapsible":true,"enabled":true,"show_spocs":true,"hardcoded_layout":true,"personalized":false,"layout_endpoint":"https://getpocket.cdn.mozilla.net/v3/newtab/layout?version=1&consumer_key=$apiKey&layout_variant=basic", "hardcoded_basic_layout": true, "spocs_endpoint": "https://getpocket.cdn.mozilla.net/v3/firefox/unique-spocs"}
  2. Load a new tab.

Ensure you only see 1 row of 3 cards in the layout, and the third card is sponsored.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Should get verified in nightly soon which would help with confidence. It's pretty low risk because it's just changing how we read prefs and if changed, allows us to revert to an older experience.
  • String changes made/needed: none
Attachment #9085285 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Attachment #9085285 - Attachment is obsolete: true
Attachment #9085285 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
Blocks: 1574334
Iteration: --- → 70.3 - Aug 5 - 18
Keywords: github-merged
Resolution: WONTFIX → FIXED
Target Milestone: --- → Firefox 70

I have verified this issue with the latest Firefox Nightly (70.0a1 Build ID - 20190822215453) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, if the "browser.newtabpage.activity-stream.discoverystream.config" pref's value is set to "{"api_key_pref":"extensions.pocket.oAuthConsumerKey","collapsible":true,"enabled":true,"show_spocs":true,"hardcoded_layout":true,"personalized":false,"layout_endpoint":"https://getpocket.cdn.mozilla.net/v3/newtab/layout?version=1&consumer_key=$apiKey&layout_variant=basic", "hardcoded_basic_layout": true, "spocs_endpoint": "https://getpocket.cdn.mozilla.net/v3/firefox/unique-spocs"}", only 3 cards are displayed on a row and the third one is sponsored.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.