Repainting of most widgets is not happening under Win98 after a period of time

RESOLVED DUPLICATE of bug 204374

Status

--
major
RESOLVED DUPLICATE of bug 204374
16 years ago
5 years ago

People

(Reporter: drewmills, Assigned: kmcclusk)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

Mozilla is not crashing but is not repainting widgets correctly.  Many widgets
will not redraw unless they get a mouse-over event.  Some (like container
widgets) won't even re-draw with a mouse-over.  Movement does not force a
re-draw so the wrong bit patterns (typically something from a window underneath
Mozilla) are moved when the browser moves.  Sometimes (not always) an expose
event does not force a repaint, sometimes it will.  All widgets seem to suffer
from this problem.

I cannot determine what starts this happening.  But Mozilla starts off behaving
well.  I have to unload Mozilla from memory and re-start it to get re-painting
to happen.

Reproducible: Always
Steps to Reproduce:
1. Use mozilla on any site.
2. Open several tabs, maybe several windows
3. It will eventually happen.

Actual Results:  Exactly the problem described.

Expected Results:  Widgets should re-paint themselves from all events like
expose, mouse-over, etc.

Machine is an AMD 900 Thunderbird with a Matrox G450 running Win93SE.
(Reporter)

Comment 1

16 years ago
An additional clue:  By minimizing and restoring the windowing several times I
was able to pin down that only two areas of the browser are re-painting upon
exposure.  The HTML rendering window (not tabs) and the sidebar rendering window
(without its title bar) are repainting.  The window elements (title bar, border,
etc.) are repainting.  But no other widgets will repaint (including menu,
navigation, status panel, links bar, and sidebar controls.

Comment 2

16 years ago
I have the same problem.  It ONLY happens in Mozilla, but it happens in the new 
1.1 alpha, and was in 1.0-release.  I don't remember how many previous editions 
it happened it, sorry.  It's quite serious and frequent.  Sometimes Mozilla has 
been running a day, or sometimes a couple of minutes, before this sets in, and 
generally it takes a reboot to fix it.  Restarting Mozilla does not fix it.  
Mouse-over displays things again.  But the actual rendered window is also 
spooged, and has to be scrolled up/down to display correctly.  A non-scrolling 
(small) page thus can't be seen, because when you click to it, the old page 
remains in place.  So do application windows that paint over the screen when 
they go in front of it.

My configuration:
Athlon 1000 (Thunderbird) with 128MB, EPoX mobo with VIA chipset. 
Matrox G400 video, 32 MB, Driver rev 6.72.016.
Win98 First Edition.  (I even upgraded IE to v6 with Windows Update hoping it 
might bring in some new base code, but that didn't help.  I am using IE6 to 
enter this note.  That does not make me happy.)

Because this is not a common bug, and doesn't occur at work on my ThinkPad, and 
I notice that the original post here also included a Matrox card, I am becoming 
suspicious that it's an interaction with the Matrox drivers.

Comment 3

16 years ago
Some additional input:  Using Mozilla 2002061104, I updated the Matrox graphics
drivers to the latest Beta level, 6.83b.  This did not help.  Nor did unchecking
"use device bitmaps caching".  I notice that Mozilla was fine last night but was
in spooged mode this morning, while the computer had just been sitting there
overnight (screen saver and monitor power-down as usual), so there was no
particular web page that caused it; there is apparently some other factor.  But
it restored to normal use after shutting down Mozilla -- it doesn't *always*
need a reboot.

When the problem does occur, the rendering window is impacted.  It only shows
new material if it's scrolled in or out; newly loaded pages aren't shown right
away, because the old page remains in place, somehow cached.  Scroll a little
and you can see part of each page up at once.

Comment 4

16 years ago
blah, this bug isn't useful, i've seen it, othes have too, but ...
Assignee: Matti → kmcclusk
Component: Browser-General → GFX Compositor
QA Contact: asa → petersen

Comment 5

16 years ago
Hello?  Is anyone in the Mozilla org even watching this bug? 
 
The bug remains present and frequent in the 1.1 released version, and as a 
point of information it also occurs in Netscape 7.0-released.  I can't find 
any workaround short of rebooting, or of course using a non-Mozilla browser. 
 

Comment 6

16 years ago
One more example.  I installed Phoenix 0.1 today.  Very nice.  But within a few 
hours, the bug had developed, impacting all Gecko-based browsers.  So the 
Phoenix widgets and the displayed window are both spooged, just like regular 
Mozilla's.

Comment 7

16 years ago
Reporter(Drew Mills), what is your graphic/video card?

Fred Goldstein, there seems to be a problem with Matrox graphic/video
card. I don't know the exact bug id for it, but bug 147845 could be
a good starting point
(Reporter)

Comment 8

16 years ago
My card information:

Installed in a Athlon Thunderbird 900Mhz
Win98SE
Matrox Millenium G450 DualHead
32MB
Software version: 4.0
Files listed for card:
    G400.drv
    *vdd,*vflatd,
    G400.vxd
    G400DD32.DLL

Updated

16 years ago
Depends on: 184933

Comment 9

16 years ago
I have the same problem. But I am using an Nvidia GeForce 2 card. Running
Mozilla 1.3a at the moment. Win 98. After some amount of time (seems kinda
random) Mozilla quits drawing pages until they are scrolled or I move the window
off the screen and back or mouse-over widgets, etc. This has been happening for
several versions at least. I have to reboot to solve the problem, restarting
Mozilla doesn't fix it. Sometimes the problem seems to go away for a minute, but
it comes back until reboot.

Comment 10

16 years ago
Same problem as comment #2 happens to me on both my wife's Win98 system and on
my parents'. Very very different hardware setup; about the only commonality is
Windows 98 (second edition). (They both have ATI video cards, but one's a Radeon
8500 and the other is an ancient Rage Pro Turbo.) Usually happens after about
half an hour of browsing, maybe sometimes a bit longer; very repeatable, but I
have no idea what triggers it. This is on Mozilla nightlies (starting several
months ago) and on Firebird release 0.6 and nightlies up to and including the
latest 20030529.

Comment 11

16 years ago
Duplicate of bug 133132?

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 12

16 years ago
dupe of bug 204374 ?
(Assignee)

Comment 13

16 years ago

*** This bug has been marked as a duplicate of 204374 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.