Closed Bug 1572624 Opened 8 months ago Closed 8 months ago

Bookmarks Menu(incl. Bookmarks Toolbar) and Bookmarks Widget popup scroll does not work with mouse wheel

Categories

(Toolkit :: XUL Widgets, defect)

70 Branch
Desktop
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: alice0775, Assigned: surkov)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

Reproducible: always

Steps To Reproduce 1:

  1. Enable Menubar and Bookmarks Toolbar
  2. Click Bookmarks menu and/or sub-folder
  3. Try scroll it with Mouse wheel

Steps To Reproduce 2:

  1. Customize toolbar and place Bookmarks Widget into toolbar
  2. Click Bookmarks Widget and/or sub-folder
  3. Try scroll it with Mouse wheel

Actual Results:
The popup would not scroll with Mouse wheel

Expected Results:
Scroll properly

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=8bd696e50a12db4f6be4ded519ef4f97ed6fed60&tochange=bd7cd9d7b6ade7bf9fa8441a8686f19c36f2a7e5

Regressed by:
bd7cd9d7b6ade7bf9fa8441a8686f19c36f2a7e5 Alexander Surkov — Bug 1539651 - Convert places-popup-base and places-popup-arrow bindings to Custom Elements r=mak

Flags: needinfo?(surkov.alexander)

Can confirm.

Same here, also the smooth scrolling effect doesn't work anymore even when scrolling with the on-hover scrollbuttons. It just jumps up or down by a whole menuitem's height.

One problem I can see here is arrowscrollbox cannot find its scrollable children, thus it fails, for example, update scrollup/down buttons. I suspect this may be the only one problem we have to fix to close this bug (and hopefully bug 1565318 as well).

Flags: needinfo?(surkov.alexander)

(In reply to alexander :surkov (:asurkov) from comment #5)

One problem I can see here is arrowscrollbox cannot find its scrollable children, thus it fails, for example, update scrollup/down buttons. I suspect this may be the only one problem we have to fix to close this bug (and hopefully bug 1565318 as well).

the second problem is arrowscrollbox scroll buttons styling is wrong, because the styles are defined in global.css, so fixing that in places-menupopup custom element will help

I don't have a mouse on my working machine, so cannot reproduce the original steps to reproduce. I think though the patch should help the original problem, so would be great to have somebody to confirm.

Assignee: nobody → surkov.alexander
Pushed by asurkov@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e0b9482a087
arrowscrollbox doesn't work properly if hosted in shadow DOM, r=dao
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Flags: qe-verify+

I didn't manage to reproduce the bug using the STR provided in the first comment on Fx 70.0a1 (2019-08-08) using Windows 10 x64 and x32. Could you please please confirm that the issue is fixed ?

You should use 09-Sep-2019 Nightly(which is including the offending patch) to reproduce.

I can reproduce the issue on Nightly70.0a1 Build ID 20190809095611.
And verified fixed on Firefox70.0b9 and Nightly71.0a1 Build ID 20190924215237.

Status: RESOLVED → VERIFIED

Hello I checked again this issue and I managed to reproduce the bug and also verify that is fixed using the builds suggested by you.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.