Mail from Outlook crashes Mozilla

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: imran.geriskovan, Assigned: Jean-Francois Ducarroz)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 2000
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020710

Mozilla crashes when displaying mails sent by peers who use Outlook..
Or at least the level of correlation is high..
Interesting enough... :))
Reporter:
Do you have a talkback ID for this crash ?
I can't reproduce this...

Updated

16 years ago
Severity: normal → critical
Keywords: crash, stackwanted
WorksForMe, but this does leave a shiver down my spine...
2002071008 on a M$ XP+SP1
(Reporter)

Comment 3

16 years ago
Incident: TB8282482H

Mail is attached. I can select amd manupulate mail.
But mozilla crashes where I try to display them.
(Reporter)

Comment 4

16 years ago
Created attachment 91233 [details]
Crashing Mail
MSVCRT.DLL + 0x2320 (0x78002320)
MimeMessage_close_headers
[c:/builds/seamonkey/mozilla/mailnews/mime/src/mimemsg.cpp, line 406]
MimeMessage_parse_line
[c:/builds/seamonkey/mozilla/mailnews/mime/src/mimemsg.cpp, line 272]
convert_and_send_buffer
[c:/builds/seamonkey/mozilla/mailnews/mime/src/mimebuf.cpp, line 134]
mime_LineBuffer [c:/builds/seamonkey/mozilla/mailnews/mime/src/mimebuf.cpp, line
256]
MimeObject_parse_buffer
[c:/builds/seamonkey/mozilla/mailnews/mime/src/mimeobj.cpp, line 261]
MimeMessage_parse_line
[c:/builds/seamonkey/mozilla/mailnews/mime/src/mimemsg.cpp, line 147]
nsStreamConverter::OnDataAvailable
[c:/builds/seamonkey/mozilla/mailnews/mime/src/nsStreamConverter.cpp, line 933]
nsStreamConverter::OnDataAvailable
[c:/builds/seamonkey/mozilla/mailnews/mime/src/nsStreamConverter.cpp, line 933]
nsDocumentOpenInfo::OnDataAvailable
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp, line 245]
nsMailboxProtocol::ReadMessageResponse
[c:/builds/seamonkey/mozilla/mailnews/local/src/nsMailboxProtocol.cpp, line 628]
nsMailboxProtocol::ProcessProtocolState
[c:/builds/seamonkey/mozilla/mailnews/local/src/nsMailboxProtocol.cpp, line 719]
nsMsgProtocol::OnDataAvailable
[c:/builds/seamonkey/mozilla/mailnews/base/util/nsMsgProtocol.cpp, line 306]
nsOnDataAvailableEvent::HandleEvent
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsStreamListenerProxy.cpp, line 204]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 597]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 530]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1078]
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 452]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1472]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1808]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1826]
WinMainCRTStartup()
KERNEL32.DLL + 0xd326 (0x77e8d326) 

Comment 6

16 years ago
wondering if this should get checked out on the 1.0 branch as well...

Comment 7

16 years ago
reassigning to ducarroz.  Jean-Francois, can you take a look at this on Monday?
Assignee: sspitzer → ducarroz

Comment 8

16 years ago
Is MimeMessage_close_headers a topcrash on the branch?

(Reporter: when did this problem of crashing when selecting a msg sent by
Outlook first start occuring for you?   Can you reproduce this with older trunk
builds?  From your comment, it appears you are seeing this crash with every
message sent from Outlook that you select?   What is the version of Outlook that
the messages are created from?)

Comment 9

16 years ago
I crash with linux build 20020709, but not 20020711 or 20020713.

looks like a dupe of bug 156650 (no subject)
(Reporter)

Comment 10

16 years ago
Mozilla crashes when

1- I double-click on the mail to view the mail (Message pane is closed)
2- I click on the mail to view the mail in message pane(Message pane is open)
3- And strange enough (I noticed recently) when I click on the "Crashing Mail"
attachment above which is an eml file.

I don't know the Outlook version. But it must be included in mail header.
(Reporter)

Comment 11

16 years ago
I've upgraded to Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+)
Gecko/20020714.

Now it does not crash.
thanks !
unsure if dupe -> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
MimeMessage_close_headers doesnot appear to be a topcrash. Also, I searched
under MSVCRT.DLL.

Comment 14

16 years ago
verified worksforme based on comment #11.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.