Closed Bug 1572695 Opened 3 months ago Closed 28 days ago

The "New Login" item is wrongly displayed after syncing or saving logins, if there were no existing logins

Categories

(Firefox :: about:logins, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- wontfix
firefox71 --- verified

People

(Reporter: cosmin.muntean, Assigned: jaws)

References

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(3 files)

[Affected Versions]:

  • Nightly 70.0a1

[Affected Platforms]

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]

  • Have a Firefox profile with no saved logins.
  • Have a FxA account with multiple saved logins.

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerequisites.
  2. Navigate to "about:logins" page.
  3. Click the "Sing in to Sync" button and log in with a valid FxA account.
  4. After the profile is synced focus the "about:logins" tab.
  5. Observe the page.

[Expected results]:

  • The first synced login is focused and display the correct information.

[Actual results]:

  • The "New Login" item is displayed in the top of the Login list and no login is focused.

[Notes]:

  • Attached a screen recording with the issue.

The issue is also reproducible when you save the first logins. In order to reproduce this behavior follow the next steps:

[Prerequisites]

  • Have a Firefox profile with no saved logins.

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerequisites.
  2. Navigate to "about:logins" page.
  3. Navigate to any website and save a login.
  4. Focus back the "about:logins" tab and observe the page.

[Expected results]:

  • The saved login is focused and the Login item is correctly displayed.

[Actual results]:

  • The "New Login" item is displayed in the top of the Login list and no login is focused.

[Notes]:

  • Attached a screen recording with this behavior.
Summary: The "New Login" item is wrongly displayed after syncing the logins, if there were no existing logins → The "New Login" item is wrongly displayed after syncing or saving logins, if there were no existing logins
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Version: 70 Branch → unspecified
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/172ede003062
Select the newly added login if it is added when there are no other logins present and we're not in the Create mode. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 28 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I have verified this issue on the latest Nightly 71.0a1 (Build ID: 20191016212918) on Windows 10 x64, Mac 10.14, Ubuntu 16.04 x64.

  • The “New Login” item is no longer displayed in the “Login List” after syncing or saving logins, if there were no existing logins.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.