Closed Bug 1572728 Opened 4 months ago Closed 4 months ago

Perma Android [Tier2] testInputConnection | Can select using key event - got 4, expected 6

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- fixed
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: m_kato)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=260767942&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/fNflA7nuSQ6G5PR_Jj6UZQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-08-09T11:02:09.892Z] 11:02:09 INFO - TEST-PASS | testInputConnection | Can select using key event - frabar should equal frabar
[task 2019-08-09T11:02:09.893Z] 11:02:09 INFO - Buffered messages finished
[task 2019-08-09T11:02:09.893Z] 11:02:09 WARNING - TEST-UNEXPECTED-FAIL | testInputConnection | Can select using key event - got 4, expected 6
[task 2019-08-09T11:02:30.595Z] 11:02:30 INFO - wait for org.mozilla.fennec_aurora complete; top activity=com.android.launcher
[task 2019-08-09T11:02:30.799Z] 11:02:30 INFO - remoteautomation.py | Application ran for: 0:01:46.933147
[task 2019-08-09T11:02:31.207Z] 11:02:31 WARNING - PROCESS-CRASH | testInputConnection | java-exception junit.framework.AssertionFailedError: TEST-UNEXPECTED-FAIL | testInputConnection | Can select using key event - got 4, expected 6 at junit.framework.Assert.fail(Assert.java:50)
[task 2019-08-09T11:02:31.207Z] 11:02:31 INFO - 0 ERROR runApp() exited with code 1
[task 2019-08-09T11:02:31.624Z] 11:02:31 WARNING - PROCESS-CRASH | Automation Error: Missing end of test marker (process crashed?)
[task 2019-08-09T11:02:32.032Z] 11:02:32 INFO - 08-09 04:01:43.606 I/GeckoTabs( 1186): zerdatime 665840 - page load start
[task 2019-08-09T11:02:32.032Z] 11:02:32 INFO - 08-09 04:01:43.606 D/GeckoToolbar( 1186): onTabChanged: START
[task 2019-08-09T11:02:32.032Z] 11:02:32 INFO - 08-09 04:01:43.616 D/GeckoBrowserApp( 1186): BrowserApp.onTabChanged: 1: START
[task 2019-08-09T11:02:32.033Z] 11:02:32 INFO - 08-09 04:01:43.746 I/dalvikvm( 1186): Jit: resizing JitTable from 4096 to 8192
[task 2019-08-09T11:02:32.041Z] 11:02:32 INFO - 08-09 04:01:44.225 D/GeckoNetworkManager( 1186): Incoming event enableNotifications for state OnWithListeners -> null
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:44.225 W/GeckoNetworkManager( 1186): Invalid event enableNotifications for state OnWithListeners
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:44.305 W/GeckoEventDispatcher( 1186): No listener for Session:DataWritten
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:45.115 D/GeckoViewAutoFill( 1186): Clearing auto-fill
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:45.696 D/GeckoToolbar( 1186): onTabChanged: TITLE
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:45.706 D/GeckoBrowserApp( 1186): BrowserApp.onTabChanged: 1: TITLE
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:45.706 D/GeckoToolbar( 1186): onTabChanged: LOCATION_CHANGE
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:45.766 D/GeckoBrowserApp( 1186): BrowserApp.onTabChanged: 1: LOCATION_CHANGE
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:46.025 D/GeckoToolbar( 1186): onTabChanged: SECURITY_CHANGE
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:46.025 D/GeckoBrowserApp( 1186): BrowserApp.onTabChanged: 1: SECURITY_CHANGE
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:46.086 D/GeckoToolbar( 1186): onTabChanged: MENU_UPDATED
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:46.086 D/GeckoBrowserApp( 1186): BrowserApp.onTabChanged: 1: MENU_UPDATED
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:48.516 D/GeckoToolbar( 1186): onTabChanged: TITLE
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:48.526 D/GeckoBrowserApp( 1186): BrowserApp.onTabChanged: 1: TITLE
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:48.526 D/Robocop ( 1186): handleMessage called for: Content:DOMTitleChanged; expecting: Content:DOMTitleChanged
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:48.546 I/Robocop ( 1186): {"message":"Content:DOMTitleChanged should equal Content:DOMTitleChanged","time":1565348508534,"source":"robocop","status":"PASS","test":"testInputConnection","thread":null,"subtest":"Given message occurred for registered event: {type=null, tabID=1, title=Robocop Input}","action":"test_status","pid":null}
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:48.546 D/Robocop ( 1186): received event Content:DOMTitleChanged
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:49.065 W/GeckoEventDispatcher( 1186): No listener for Website:AppLeft
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:49.065 W/GeckoEventDispatcher( 1186): No listener for Website:AppLeft
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:50.076 E/GeckoConsole( 1186): [JavaScript Error: "Unknown Collection "main/hijack-blocklists"" {file: "resource://services-settings/RemoteSettingsClient.jsm" line: 172}]
[task 2019-08-09T11:02:32.042Z] 11:02:32 INFO - 08-09 04:01:50.076 E/GeckoConsole( 1186): UnknownCollectionError@resource://services-settings/RemoteSettingsClient.jsm:172:5
[task 2019-08-09T11:02:32.043Z] 11:02:32 INFO - 08-09 04:01:50.076 E/GeckoConsole( 1186): sync@resource://services-settings/RemoteSettingsClient.jsm:354:13

See Also: → 1501960
Assignee: nobody → m_kato
Flags: needinfo?(m_kato)

Makoto says (bug 1563640 comment 9) that, if we want to uplift the fix for SwiftKey bug 1572728, we would need to also uplift this test fix. TBD whether we do want to uplift these fixes to GV 69 Beta or Fennec ESR 68.

Actually, assertTextAndSelectionAt checks Java side text and selection. So
even if assertTextAndSelectionAt is successful, Gecko's text and selection
aren't updated yet. Since sendKeyEvent test uses both Gecko's selection (to
insert text by key event) and Java's selection, this has timing issue. After
landing bug 1563640, we don't send unnecessary range to Gecko, so if Gecko's
selection isn't updated yet, the selection may be invalid.

To sync both data, this test should always use key event to update both Gecko
side and Java side correctly. GV's test uses Gecko's selection, so this issue
is robocop test only.

Attachment #9086587 - Attachment description: Bug 1572728 - Sync Gecko's text event for sendKey test. r? → Bug 1572728 - Sync Gecko's selection for sendKey test of testInputConnection. r?
Priority: -- → P2
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/bb869a498703
Sync Gecko's selection for sendKey test of testInputConnection. r=geckoview-reviewers,snorp
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Comment on attachment 9086587 [details]
Bug 1572728 - Sync Gecko's selection for sendKey test of testInputConnection. r?

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: This is test only fix after landing bug 1563640
  • User impact if declined: This is test only fix after landing bug 1563640. This fixes timing issue for testInputConnection.
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): test only fix. If bug 1563640 is rejected, it is unnecessary to land this.
  • String or UUID changes made by this patch: no
Attachment #9086587 - Flags: approval-mozilla-esr68?

Comment on attachment 9086587 [details]
Bug 1572728 - Sync Gecko's selection for sendKey test of testInputConnection. r?

Fixes a test regression from bug 1563640. Approved for Fennec 68.2b2.

Attachment #9086587 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
You need to log in before you can comment on or make changes to this bug.