Closed Bug 1572800 Opened Last month Closed Last month

Enable "text-decoration-skip-ink" by default on Nightly/early-beta

Categories

(Core :: Layout: Text and Fonts, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: dholbert, Assigned: cmarlow)

References

(Depends on 1 open bug, Regressed 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

We should consider enabling text-decoration-skip-ink by default on Nightly, to get some early testing even if it's not quite ready to ride the trains. (And text-decoration-thickness and text-underline-offset as well, actually.)

If there are any known serious bugs that would need to be fixed before doing that, then we should mark them as blocking this bug.

Once we're ready to do this, I think the patch is just a one-liner, replacing false with @IS_NIGHTLY_BUILD@ in the snippet for each pref in the yaml file, e.g. here:
https://searchfox.org/mozilla-central/rev/ab6f4c453d15ab82147c630a8b886b40240ca72b/modules/libpref/init/StaticPrefList.yaml#4044

Depends on: 1572291

(er, copypaste error -- didn't mean to make this dependent on bug 1572709. If that bug were a real regression caused by this feature, it probably would be a good dependency, but it looks like that's not at all clear right now.)

RE depending on bug 1572291: I suspect we could go either way on that blocking this bug - definitely blocks shipping, but perhaps doesn't need to block enabling by default on Nightly if we want to get this tested sooner. (jfkthame may have opinions on this too.)

As long as we fail gracefully (e.g. if we just draw the full line, like normal), I don't think it's a huge problem to enable by default on Nightly with bug 1572291 unfixed.

Depends on: 1411922
No longer depends on: 1572709

I'm hoping to submit the patch to jfkthame for that bug either later today or early next week, but I agree it doesn't make a huge difference if it fails gracefully.

I don't have any objection to enabling this on Nightly even before bug 1572291 is done.

I'd favor turning on all the new text-decoration features at the same time, and aiming to let them all ride the trains together when we're ready to ship to release; I think it'll be easier for authors if we treat them as a "package deal" that all come together.

Setting the 'dev-doc-needed' keyword, so I remember to update https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features once the patch for this landed.

Just a friendly reminder here that it would be awesome if the reporter or implementer already set that flag on things that should be mentioned on MDN web docs and/or https://platform-status.mozilla.org/.

Sebastian

Keywords: dev-doc-needed
Depends on: 1573249
Blocks: 1573631
Attachment #9085322 - Attachment description: Bug 1572800: Part 1: Enable text-decoration-skip-ink by default on Nightly → Bug 1572800: Part 1: Enable text-decoration-skip-ink by default on Nightly r?dholbert

Note to self: when this lands, we should also land bug 1573724 and bug 1573725.

Also, one common nit for all three bugs: the patch's commit message should say "nightly and early beta" rather than "Nightly". Toggling needinfo=cmarlow to fix that across all three commits.

Flags: needinfo?(charles.w.marlow)
Summary: Enable "text-decoration-skip-ink" by default on Nightly → Enable "text-decoration-skip-ink" by default on Nightly/early-beta

(In reply to Daniel Holbert [:dholbert] from comment #7)

Note to self: when this lands, we should also land bug 1573724 and bug 1573725.

Also, one common nit for all three bugs: the patch's commit message should say "nightly and early beta" rather than "Nightly". Toggling needinfo=cmarlow to fix that across all three commits.

Actually, since phabricator makes it easy, I just hand-edited the commit messages in the webUI to add "(in early-beta and earlier) " and landed those other patches. And we can land this bug's patches, too, in a bit, once we've got the .ini fix in part 0.

Flags: needinfo?(charles.w.marlow)
Assignee: nobody → charles.w.marlow
Status: NEW → ASSIGNED
Attachment #9085322 - Attachment description: Bug 1572800: Part 1: Enable text-decoration-skip-ink by default on Nightly r?dholbert → Bug 1572800: Part 1: Enable text-decoration-skip-ink by default on Nightly (and early-beta and earlier) r?dholbert
Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97d2c2478643
Part 0: Add text-decoration-skip-ink: none to currently failing test cases r=dholbert
https://hg.mozilla.org/integration/autoland/rev/ac9ebd3dead0
Part 1: Enable text-decoration-skip-ink by default on Nightly (and early-beta and earlier) r=dholbert
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/18430 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Depends on: 1574392
No longer depends on: 1574392
Regressions: 1574392
Regressions: 1574031
Regressions: 1574306
Regressions: 1574641
Depends on: 1574927

This still looks broken, as described here:
http://forums.mozillazine.org/viewtopic.php?f=23&t=3053225

Added the info that it's enabled by default on Nightly. See https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features#text-decoration-skip-ink, plus text-decoration-thickness and text-underline-offset.

Sebastian

(In reply to Worcester12345 from comment #13)

This still looks broken, as described here:
http://forums.mozillazine.org/viewtopic.php?f=23&t=3053225

There's not a lot of info on that page. (I just see someone expressing an opinion that it "simply looks, odd".)

If you have a particular scenario in mind where it looks odd/broken (where Chrome/Safari do not look similarly-odd to you), would you mind filing a bug with more info, and posting the bug link here?

You need to look at the photos there, and you will see.

I see only a single "before/after" screenshot on that thread, and it looks fine to me...

Again: if something is wrong, please file a bug with a clear description of what you think is wrong. (If particular underline-gaps look especially broken, please be specific.)

This bug here is closed, so it's not a great place to have a back-and-forth about followup issues (but is a great way to tie together follow issues that are tracked in their own separate followup bugs.)

Regressions: 1575262
No longer regressions: 1575262
Depends on: 1575338
Depends on: 1575383
You need to log in before you can comment on or make changes to this bug.