Closed Bug 1572836 Opened 1 year ago Closed 1 year ago

releasing off comm-esr68

Categories

(Thunderbird :: Build Config, defect)

defect
Not set
normal

Tracking

(thunderbird_esr68 fixed)

RESOLVED FIXED
Thunderbird 68.0
Tracking Status
thunderbird_esr68 --- fixed

People

(Reporter: rjl, Assigned: rjl)

References

Details

Attachments

(3 files)

Will use this bug to track build config issues related to doing the initial release of Thunderbird 68.0 off comm-esr68.

First up, build signing issues due to comm-esr68 not being recognized as a release branch.

Attaching so it can get into the THUNDERBIRD_68_VERBRANCH, will submit
to Phabricator for inclusion in M-C later.
Assignee: nobody → rob
Status: NEW → ASSIGNED
Flags: needinfo?(jorgk)
See Also: → 1552389
This patch will not apply on c-c, as this particular change is already
present from work done in bug 1569539.

We may eventually uplift that bug, but it's pretty big and this is a relatively
safe change.

Try build successful with a beetmover upload:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=afcd4cf438775784f908ae1da2692cd5413637a6

Uploaded to:
http://ftp.stage.mozaws.net/pub/thunderbird/nightly/2019/08/2019-08-12-19-12-48-try-comm-central/gdata-provider.en-US.xpi

Hmm, I think your talking about bug 1516816 and some of this: https://hg.mozilla.org/comm-central/rev/e1a0f9d5e69c#l1.12

Comment on attachment 9084854 [details] [diff] [review]
gdata-provider-artifact-filename.patch

This fixes the missing linux64-en-US builds from 68.0-build2.
Scriptworker does not expand variables in artifact filenames so '${locale}' needs to be dropped.

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): tested on try-comm-central, including the beetmove job that currently fails on comm-esr68
Risk to taking this patch (and alternatives if risky):
Minimal risk, the end result of this change is gdata-provider.en-US.xpi is now named gdata-provider.xpi. Geoff this particular change is in C-C already. It should be mentioned in the release notes in case a downstream packager relies on that filename.
Attachment #9084854 - Flags: review?(jorgk)
Attachment #9084854 - Flags: approval-comm-esr68?
Comment on attachment 9084854 [details] [diff] [review]
gdata-provider-artifact-filename.patch

I'll push it now.
Attachment #9084854 - Flags: review?(jorgk) → review+
Attachment #9084854 - Flags: approval-comm-esr68? → approval-comm-esr68+

(In reply to Jorg K (GMT+2) from comment #4)

Hmm, I think your talking about bug 1516816 and some of this: https://hg.mozilla.org/comm-central/rev/e1a0f9d5e69c#l1.12

Yes, but that was only needed because of the changes in bug 1569539.

What are we going to do for beta when neither bug 1516816 nor bug 1569539 are going there? This hasn't been an issue on TB 69 beta for some reason. So we do nothing for that beta, right?

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 68.0

Ahh. This got messy. The first part of bug 1516816 is on beta: https://hg.mozilla.org/releases/comm-beta/rev/9344b60b89f062d9f49f916aca27b65180ee4f90, so it will run into the linux64-en-US bug.

Okay so I'm not completely crazy then, because I remember checking that I could use a variable there...
https://searchfox.org/mozilla-beta/source/taskcluster/taskgraph/util/scriptworker.py#478-482

Beta can handle it, currently esr68 cannot.

This bug broke the tests. This patch should fix the tests. r+ from rjl on IRC.

Attachment #9090569 - Flags: review+
Attachment #9090569 - Flags: approval-comm-esr68?
Comment on attachment 9090569 [details] [diff] [review]
1572836-fetch-gdata-1.diff

https://hg.mozilla.org/releases/comm-esr68/rev/3b8380bf4c660ed42b976cda98cbacb46c64e122
More gData fun :-(
Attachment #9090569 - Flags: approval-comm-esr68? → approval-comm-esr68+
You need to log in before you can comment on or make changes to this bug.