Closed Bug 1572970 Opened 11 months ago Closed 11 months ago

When clicking a link in Thunderbird, default browser (Firefox) is lauched but stays in background window

Categories

(Thunderbird :: OS Integration, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 70.0

People

(Reporter: mikeleo, Unassigned)

References

(Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

When I click on a link, the page loads in Firefox(my default browser), but the computer stays in Thunderbird. (v69.0b2)

Actual results:

Stays in Thunderbird

Expected results:

It should have brought up the Firefox program and went to the linked page.

Firefox comes up for me when I click a link in a message using TB 69.0b2 on Ubuntu 18.04.3 LTS Linux.

I have Firefox as my default browser set in the General Firefox preferences, TB 69.0b2 as my default email application in Thunderbird's Advanced > General preferences and as the default applications in my operating systems settings.

Is that the way you are setup on Windows?

Flags: needinfo?(mikeleo)

Yes. Firefox is my default browser and Thunderbird is my default mail client. I am running Windows 10. This just started happening recently.

Flags: needinfo?(mikeleo)

(In reply to mikeleo from comment #2)

Yes. Firefox is my default browser and Thunderbird is my default mail client. I am running Windows 10. This just started happening recently.

That answers two of the three settings question, or I didn't understand you meant in each application and Windows 10.

Default applications in Windows 10

Settings > Apps > Default in Windows

Links bring Firefox in focus when I click a link in a message for me with TB 60.8.0 and Firefox 68.0.1 on my Windows 10 laptop.

I am also running TB 60.8.0 on my laptop and it works fine there also. Apparently something happened with the new version.

I can see that in TB 69 beta 2. I click in a link in TB, and FF launches, but the TB windows stays in top.

Alice, do you see this as well? Can you find the regression. Many thanks in advance.

Flags: needinfo?(alice0775)
Summary: links not working properly → When clicking a link in Thunderbird, default browser (Firefox) is lauched but stays in background window

I can reproduce the issue. But sometimes, I cannot reproduce the issue.
This is slightly inconsistent.

Regression window(Good -> Bad(sometimes Good)):
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=166ccd934db34e30db0588952e598b410840cab6&tochange=b56bdad8ff021b74dc1c6cc64ecaf955a2f6f04f
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5b35e2ff7c15cc2f4d1eb419a18d899294560243&tochange=5805cd9ae2947386263069e1a3b2d832384bd45f

Unfortunately, there are no Win6(32) builds between the above range.

Flags: needinfo?(alice0775)

s/Win6(32)/Win64(Win32)/

Thanks, Alice. BTW, some people can edit comments on BMO now to correct typos, etc. Above each of my comments I see four icons:
Edit (pen), tag, arrow (reply), minus (collapse). You don't have the edit (pen)?

As for the regression: It happened when FF switched the main windows to XHTML in
fd2b93ff0abecc11bcfbcd806262c79f5de50b9b Brendan Dahl — Bug 1550801 - Load XUL documents as XHTML documents. r=smaug
In the range there are also many other windows related changes.

Does something similar happen in FF, like "Open link in new window", is the new window always in the foreground?

Does this happen on Linux? There are a few more builds for Linux in the range given above.

Something else can could be tried: Open an Windows explorer window to a folder with an HTML document. Double-click the document. Does the FF window open in the foreground?

Keywords: regression

Most likely caused by bug 1567614, also see some other regression, bug 1570845.

Regressed by: 1567614
Status: UNCONFIRMED → NEW
Component: Untriaged → OS Integration
Ever confirmed: true

I noticed something new today. I'm not certain if this is 100% or not, but it seems like it is now working if the link starts with "http" and not "https"

My last theory failed today. "http" didn't work. I'll try to find a new theory.

updated to 69.0b3. No change

I tried the html file in Windows explorer and it worked the way it should. (FF came to the top)

Blocks: tb68found
See Also: → 1570845

The fix for Bug 1570845 was released as Nightly. Would anybody check the latest Thunderbird, please?

https://archive.mozilla.org/pub/thunderbird/nightly/2019/08/2019-08-26-22-40-09-comm-central/

I'll make an uplift request.

Duplicate of this bug: 1576022

As far as I can see, this is FIXED by bug 1570845. We'll watch the backports. Thanks for the fix.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0

updated to 69.0b4 today. No change.

Yes, but it will be fixed in TB 70 beta and TB 68.1 ESR.

Thank you very much

Jorg K wrote:

We'll watch the backports

I for one would appreciate a backport. For I have this problem (on Linux) and I imagine that the release version of Thunderbird 70 is a long way away.

This was only ever a Windows issue and the has been backported for TB 68.1.0, I think. Not sure now, but certainly fixed in the latest version 68.2.2.

@Jork: in that case, if I find the will, I had better start a new but report.

You need to log in before you can comment on or make changes to this bug.