Closed Bug 1573026 Opened 2 years ago Closed 2 years ago

Perma /builds/worker/workspace/build/src/dom/xul/XULPersist.cpp:206:8: error: member access into incomplete type 'nsIStringEnumerator' when Gecko 70 merges to Beta on 2019-08-26

Categories

(Core :: XUL, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 + verified

People

(Reporter: rmaries, Assigned: bdahl)

References

(Regression)

Details

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as Beta: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=786285ac114345b979bbe35d913386661f0246f9&selectedJob=261024858

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=261024858&repo=try&lineNumber=23015

[task 2019-08-11T13:00:03.528Z] 13:00:03 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/dom/payments'
[task 2019-08-11T13:00:03.896Z] 13:00:03 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/dom/xul'
[task 2019-08-11T13:00:03.896Z] 13:00:03 INFO - /builds/worker/workspace/build/src/sccache/sccache /builds/worker/workspace/build/src/clang/bin/clang++ -o Unified_cpp_dom_xul0.o -c -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DMOZ_BREAK_XUL_OVERLAYS -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/dom/xul -I/builds/worker/workspace/build/src/obj-firefox/dom/xul -I/builds/worker/workspace/build/src/docshell/base -I/builds/worker/workspace/build/src/dom/base -I/builds/worker/workspace/build/src/dom/html -I/builds/worker/workspace/build/src/dom/xbl -I/builds/worker/workspace/build/src/dom/xml -I/builds/worker/workspace/build/src/layout/base -I/builds/worker/workspace/build/src/layout/generic -I/builds/worker/workspace/build/src/layout/style -I/builds/worker/workspace/build/src/layout/xul -I/builds/worker/workspace/build/src/layout/xul/tree -I/builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders -I/builds/worker/workspace/build/src/ipc/chromium/src -I/builds/worker/workspace/build/src/ipc/glue -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -U_FORTIFY_SOURCE -fno-common -Qunused-arguments -Wall -Wbitfield-enum-conversion -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wtautological-unsigned-enum-zero-compare -Wtautological-unsigned-zero-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=backend-plugin -Wno-error=return-std-move -Wno-error=atomic-alignment -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -fsanitize=bool,bounds,vla-bound -fno-sanitize-recover=bool,bounds,vla-bound -fsanitize-blacklist=/builds/worker/workspace/build/src/obj-firefox/ubsan_blacklist.txt -fsanitize=address -fcrash-diagnostics-dir=/builds/worker/artifacts -U_FORTIFY_SOURCE -fno-common -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -O2 -gline-tables-only -fno-omit-frame-pointer -funwind-tables -Werror -Wno-error=shadow -MD -MP -MF .deps/Unified_cpp_dom_xul0.o.pp /builds/worker/workspace/build/src/obj-firefox/dom/xul/Unified_cpp_dom_xul0.cpp
[task 2019-08-11T13:00:03.896Z] 13:00:03 INFO - In file included from /builds/worker/workspace/build/src/obj-firefox/dom/xul/Unified_cpp_dom_xul0.cpp:29:
[task 2019-08-11T13:00:03.896Z] 13:00:03 ERROR - /builds/worker/workspace/build/src/dom/xul/XULPersist.cpp:206:8: error: member access into incomplete type 'nsIStringEnumerator'
[task 2019-08-11T13:00:03.896Z] 13:00:03 INFO - ids->HasMore(&hasmore);
[task 2019-08-11T13:00:03.897Z] 13:00:03 INFO - ^
[task 2019-08-11T13:00:03.897Z] 13:00:03 INFO - /builds/worker/workspace/build/src/obj-firefox/dist/include/nsIXULStore.h:19:7: note: forward declaration of 'nsIStringEnumerator'
[task 2019-08-11T13:00:03.897Z] 13:00:03 INFO - class nsIStringEnumerator; /* forward declaration /
[task 2019-08-11T13:00:03.897Z] 13:00:03 INFO - ^
[task 2019-08-11T13:00:03.897Z] 13:00:03 INFO - In file included from /builds/worker/workspace/build/src/obj-firefox/dom/xul/Unified_cpp_dom_xul0.cpp:29:
[task 2019-08-11T13:00:03.897Z] 13:00:03 ERROR - /builds/worker/workspace/build/src/dom/xul/XULPersist.cpp:212:8: error: member access into incomplete type 'nsIStringEnumerator'
[task 2019-08-11T13:00:03.898Z] 13:00:03 INFO - ids->GetNext(id);
[task 2019-08-11T13:00:03.898Z] 13:00:03 INFO - ^
[task 2019-08-11T13:00:03.899Z] 13:00:03 INFO - /builds/worker/workspace/build/src/obj-firefox/dist/include/nsIXULStore.h:19:7: note: forward declaration of 'nsIStringEnumerator'
[task 2019-08-11T13:00:03.900Z] 13:00:03 INFO - class nsIStringEnumerator; /
forward declaration /
[task 2019-08-11T13:00:03.900Z] 13:00:03 INFO - ^
[task 2019-08-11T13:00:03.901Z] 13:00:03 INFO - In file included from /builds/worker/workspace/build/src/obj-firefox/dom/xul/Unified_cpp_dom_xul0.cpp:29:
[task 2019-08-11T13:00:03.902Z] 13:00:03 ERROR - /builds/worker/workspace/build/src/dom/xul/XULPersist.cpp:270:10: error: member access into incomplete type 'nsIStringEnumerator'
[task 2019-08-11T13:00:03.902Z] 13:00:03 INFO - attrs->HasMore(&hasmore);
[task 2019-08-11T13:00:03.902Z] 13:00:03 INFO - ^
[task 2019-08-11T13:00:03.903Z] 13:00:03 INFO - /builds/worker/workspace/build/src/obj-firefox/dist/include/nsIXULStore.h:19:7: note: forward declaration of 'nsIStringEnumerator'
[task 2019-08-11T13:00:03.903Z] 13:00:03 INFO - class nsIStringEnumerator; /
forward declaration */
[task 2019-08-11T13:00:03.903Z] 13:00:03 INFO - ^
[task 2019-08-11T13:00:03.903Z] 13:00:03 INFO - In file included from /builds/worker/workspace/build/src/obj-firefox/dom/xul/Unified_cpp_dom_xul0.cpp:29:
[task 2019-08-11T13:00:03.904Z] 13:00:03 ERROR - /builds/worker/workspace/build/src/dom/xul/XULPersist.cpp:276:10: error: member access into incomplete type 'nsIStringEnumerator'

Brendan, this seems to be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1551344.
Could you take a look?

Flags: needinfo?(bdahl)

Must be a beta build difference and we just need to include that header file. Looking into now...

Flags: needinfo?(bdahl)

Beta builds use the old XUL store which was missing a header after the
removal of XULDocument.

Assignee: nobody → bdahl
Pushed by bdahl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3dbe36ad7765
Include missing header in XULPersist for old XUL store. r=smaug
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.