Closed Bug 1573159 Opened 3 months ago Closed 3 months ago

The "Login List" is automatically scrolled to display the clicked login on the first position in the view content

Categories

(Firefox :: about:logins, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified

People

(Reporter: simona.rosu, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [passwords:management] [skyline])

Attachments

(2 files)

Attached video LoginList_scrolled.mp4

[Affected versions]:

  • Firefox latest Nightly 70.0a1 (2019-08-11) (64-bit)

[Affected Platforms]:

  • Mac 10.14
  • Windows 10 x64
  • Ubuntu 18.04 x64

[Prerequisites]:

  • Have a Firefox profile with a lot of saved logins.

[Steps to reproduce]:

  1. Open the browser and navigate to the "about:logins" page.
  2. Click a saved login from the middle of the “Login List”.
  3. Observe the behavior.

[Expected result]:

  • The login is selected and the “Login List” is not scrolled.

[Actual result]:

  • The “Login List” is scrolled to display the clicked login on the first position in the view content.

[Regression]

  • The issue is not reproducible with older Nightly 70.0a1 builds. Considering this, using mozregression tool I have found the issue that broke this in the latest Nightly build. Here are the results:
  • Pushlog: https://tinyurl.com/y5askx2o
  • Last good revision: cf5636790ad4c39688bf6a84f77b53fb818654f4
  • First bad revision: 5f21c67e96473c611c9fc6b3bb81d355bd73cf2c

From this pushlog it seems that bug 1572041 introduced this behavior.

[Additional notes]:

  • Attached a screen recording with the issue.
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0bbcb428a2f9
Only call scrollIntoView() on login-list item if it isn't in view. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

I have verified this issue on the latest Nightly 70.0a1 (2019-08-16) (64-bit) on Windows 10, MacOS 10.14 and Ubuntu 18.04.
- The "Login List" is not scrolled when select any login from the list.

Status: RESOLVED → VERIFIED
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
You need to log in before you can comment on or make changes to this bug.