Closed Bug 1573161 Opened 3 months ago Closed 3 months ago

Bookmark separators are disrupted inside Library

Categories

(Firefox :: Theme, defect, P3, minor)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- verified
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: Anca, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image issue screenshot.png

[Affected versions]:

  • 70.0a1 (2019-08-11)
  • 69.0b12
  • 68.0.1

[Affected platforms]:

  • Windows 10
  • Ubuntu 18.04
  • macOS 10.13

[Steps to reproduce]:

  1. Open Library (CTRL+Shift+B)
  2. Go to any subsection from All Bookmarks section
  3. Right-click - New Separator

[Expected result]:

  • The separator is not disrupted

[Actual result]:

  • The separator is disrupted

[Regression range]:

[Additional Notes]:

  • Issue is more visible on hover.
Has Regression Range: --- → yes
Has STR: --- → yes

ntim, this appears to be your regression. Could you look into this?

Flags: needinfo?(ntim.bugs)
Priority: -- → P3
Assignee: nobody → ntim.bugs
Flags: needinfo?(ntim.bugs)
Attachment #9085155 - Attachment description: Bug 1573161 - Restore padding: 0; on ::-moz-tree-twisty(title, separator). r=dao → Bug 1573161 - Restore padding: 0; on ::-moz-tree-twisty(title, separator) in tree-icons.css. r=dao
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f815b5977a4f
Restore padding: 0; on ::-moz-tree-twisty(title, separator) in tree-icons.css. r=dao
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Please nominate this for Beta & ESR68 approval when you get a chance.

Flags: needinfo?(ntim.bugs)

Comment on attachment 9085155 [details]
Bug 1573161 - Restore padding: 0; on ::-moz-tree-twisty(title, separator) in tree-icons.css. r=dao

Beta/Release Uplift Approval Request

  • User impact if declined: Visual bug in bookmarks library separators
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0 (it would also be nice to test on all 3 platforms)
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Restores some small CSS that shouldn't have been removed.
  • String changes made/needed: No
Flags: needinfo?(ntim.bugs)
Attachment #9085155 - Flags: approval-mozilla-esr68?
Attachment #9085155 - Flags: approval-mozilla-beta?
Flags: qe-verify+

This issue is verified fixed with Fx 70.0a1 (2019-08-15) on Windows 10, Ubuntu 18.04 and macOS 10.13.

Comment on attachment 9085155 [details]
Bug 1573161 - Restore padding: 0; on ::-moz-tree-twisty(title, separator) in tree-icons.css. r=dao

Simple CSS fix. Approved for 69.0b15 and 68.1esr.

Attachment #9085155 - Flags: approval-mozilla-esr68?
Attachment #9085155 - Flags: approval-mozilla-esr68+
Attachment #9085155 - Flags: approval-mozilla-beta?
Attachment #9085155 - Flags: approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

This issue is also verified fixed with Fx 69.0b15 on Windows 10, Ubuntu 18.04 and macOS 10.13.

The issue is no longer reproducible with 68.1.0esr (20190823201228) on Windows 10, Ubuntu 18.04 and macOS 10.13.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.