[CRASHER][TESTCASE] alert() crashing application.

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: desale, Assigned: vidur)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Simple alert is crashing apprunner.

BUILD: 10-06-09 [Apprunner]

STEPS TO REPRODUCE:
1] copy HTML code I'm providing. Save it as HTML file.
2] Open this file with apprunner.
3] you'll see one button "Show Me Alert". Click this button.
4] Now you'll see one alert "Simple alert". click OK on this alert.
5] Click "Show Me Alert" again. Now you'll see crash.
6] If you try same alert two three times, it crashes application.
[If you don't see crash, click "Show Me Alert" multiple times]

EXPECTED RESULTS:
Everytime we click "Show Me Alert", we should see alert.

ACTUAL RESULTS:
After two three clicks, application crashes.

CODE:

<html>
<head>
<title>Test Page</title>
</head>
<SCRIPT LANGUAGE="JavaScript1.1">
<!--
function justalert(){
alert('Simple Alert');
}
//-->
</SCRIPT>
<body>
<FORM NAME="workform">
<INPUT TYPE="button" NAME="but3" VALUE="Show Me Alert" onClick="justalert();">
</FORM>
</body>
</html>

END OF CODE:
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 1

19 years ago
I don't see the crash in apprunner, though I believe that might be because of a
fix from Norris yesterday.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

19 years ago
Tested on 10-15-09. Working fine now. Marking verified.
You need to log in before you can comment on or make changes to this bug.