browser hangs and must be killed

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: wing-tung Leung, Assigned: Matti)

Tracking

({crash, stackwanted, testcase})

Trunk
x86
Linux
crash, stackwanted, testcase
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
mozilla 1.0 rc2 on i386 GNU/Linux.

Loading above page hangs the browser after a few seconds. Nothing is displayed,
and the progressbar is halfway, but does not move anymore.

I guess this bug partially belongs to Evangelism, but IMHO, the browser should
NEVER completely hang.

Comment 1

16 years ago
WFM, current trunk CVS, Linux.
There is a flash animation popping up in a separate window there.
Do you have flash plugin installed?
Does it hang if you disable it?
Are you playing sounds or otherwise keeping /dev/dsp open when the hang occures?

Comment 2

16 years ago
Created attachment 91229 [details]
Testcase (may crash mozilla!)

Crashes / Hangs 20020711 on Linux (Debian woody)

The Combination of
<meta http-equiv="Content-Type" content="text/html; charset=big5"> ..and..
è° ..is the problem..
That's very strange.. if you replace è° with °è, mozilla doesn't crash/hang !
I think thats a dup of bug 156882

Comment 3

16 years ago
-> Critical
cc'ing myself and adding keywords

oh btw: the testcase may or may not crash on your build.. (it doesn't here.. but
it hangs a _very long time_ .. the orginal page does hang and crashes after a
long time..)

It seems that some evil combinations of chars & charset are existing..
The testcase has just one evil combination (mozilla doesn't crash) .. the
orginal page seems to have more evil combinations (bad for mozilla)
Severity: major → critical
Keywords: crash, stackwanted, testcase
(Reporter)

Comment 4

16 years ago
I don't have any trouble with the testcase (no hang).

I tried to remove the Flash and Java plugin, it looked like it helped because
the page is partially shown, but it still hangs in a later phase. Reinstalling
the plugins didn't make the page loading worse again. What I have now: java
1.3.1 plugin, flash, shockwave. Most of the time the page seems to load fine the
first time, but the reload (or <Shift> - Reload) triggers a hang. Often, but not
always. ;-(
(Assignee)

Comment 5

16 years ago
The bug report itself is invalid (RC2 is already very old..) unless someone can
reproduce this with a recent build.



Comment 6

16 years ago
Matthias:

See comment #2 .. 20020711 isn't very old..

Comment 7

16 years ago
worksforme, linux build 20020713.  tescase and URL load quickly and don't crash.

Adrian, are you using a Debian package or a mozilla-built build?

Comment 8

16 years ago
I'm using mozilla.org builds. (of course :) )

It's exactly the same thing like bug 156882 for me..


Andrew:
I think that's a dup of 156882, even when the testcase here works for you and
156882 crashes for you..

What distribution are you using Andrew?
I tested it on Debian woody (x86/ppc) and Slack 8, both are affected.

Comment 9

16 years ago
Seems like i have to many fonts installed on my system...

1) I removed the ttf Direcotry from the XF86Config (has many fonts..) result:
881903.com works perfect
job.ge (from  bug 156882) does hang a long time but not crash..

2) I added the ttf directory back into the XF86Config. The fonts.dir of my ttf
directory had about ~1200 lines.. i removed 1000 lines. Result:
881903.com does show up in about 5 seconds
job.ge also

btw: i'm not using a fontserver for TTF fonts.
Tested with XFree 4.1.0.1 (debian default) and 4.2 on Slack

Comment 10

16 years ago
> I'm using mozilla.org builds. (of course :) )

if you weren't, you could get a stack...

I'm running RedHat 7.3

> Seems like i have to many fonts installed on my system...

That's consistent with what I see in bug 156882, which hits the CPU looking for
a font.  I had truetype fonts disabled and hoped that enabling would get a crash
in bug 156882 and a hang here.  After enabling them here, no change.  and bug
156882 was "fixed" by enabling freetype.  argh!

Comment 11

16 years ago
wfm, current CVS, Linux
(Reporter)

Comment 12

16 years ago
Upgraded to mozilla-1.0, no flash, no java. Page loads and displays fine, normal
reload works as well, but <Shift>+Reload hangs the browser.

Current system is upgraded RedHat 6.2, with 2.4.18 kernel and XFree-4.2.

Also tried mozilla-1.0 on a RedHat 7.3 system, which seems to work fine.

Comment 13

16 years ago
Marking WORKSFORME as per reporter comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey

Comment 14

10 years ago
Crashtest added as part of http://hg.mozilla.org/mozilla-central/rev/afc662d52ab1
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.