Closed Bug 1573236 Opened 2 months ago Closed 2 months ago

Port the Storage Access API heuristics, as well as its telemetry to Gecko

Categories

(Core :: Privacy: Anti-Tracking, task)

task
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: ehsan, Assigned: ehsan)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Right now the automatic access grants of the storage access API are implemented in the browser/ front-end code because we need access to functionality implemented in BrowserUsageTelemetry.jsm. Also, the telemetry for this API is implemented in the front-end as well, for no good reason really.

Porting these two bits over to Gecko would mean that enabling the Storage Access API on GeckoView would be much simpler, that is, we would only need to worry about implementing the prompt as well as the minimal BrowserUsageTelemetry.jsm support on GeckoView.

I have a patch for this which moves both parts over to Gecko. The reason I'm moving both simultaneously is that they both happen around the same code and moving them one by one would have required needless extra surgery.

Depends on: 1573238

This will allow these heuristics to be used on mobile.
This depends on GeckoView supporting a JavaScript module
at resource:///modules/BrowserUsageTelemetry.jsm with the
interface described in nsIBrowserUsage.idl. Bug 1573238 has
been filed in order to implement this module on GeckoView.

Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a60edc93a434
Part 1: Move the Storage Access API heuristics and telemetry from the front-end to Gecko; r=johannh,baku
https://hg.mozilla.org/integration/autoland/rev/6e1475b54a6f
Part 2: Make the dom.storage_access.auto_grants.delayed work again with the new setup; r=baku

This got left out of changeset a60edc93a434 during rebase.

Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2d3159992a61
Also allow collection in the main process for the single-process case
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1577563
You need to log in before you can comment on or make changes to this bug.