Closed Bug 1573279 Opened Last month Closed 29 days ago

Add a preference to control the Picture-in-Picture video toggle

Categories

(Firefox :: Preferences, enhancement)

enhancement
Not set

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

The Picture-in-Picture toggle is displayed on videos when the mouse hovers over them. Some users might not want to ever use the feature, and might find the toggle intrusive. We're hoping to give them the ability to disable the toggle in bug 1568320, but we also need to give them the ability to turn it back on in case it's disabled by accident or the user changes their mind.

Product suggested adding a new checkbox to about:preferences, so this bug is about doing that.

Hi mheubusch,

I reached out a few weeks ago about this, but went on PTO. I'm back now, and so this is the bug I promised you I'd file about adding a checkbox to about:preferences for the Picture-in-Picture toggle. Who should I speak to about figuring out how best to integrate this option?

Flags: needinfo?(mheubusch)
Duplicate of this bug: 1572768

Mike,

Aligned with @emanuela

Can we go with:

Enable picture-in-picture video controls

and place the control in General > Browsing

Open questions:

Are we using picture-in-picture or picture in picture in other interface elements? We should be consistent.

If possible, it'd be great to have a SUMO article with additional detail and a Learn more link.

Flags: needinfo?(mheubusch)

Thanks for looping me in @jpfaller

We'll work on a SUMO article when this is in Beta (need-infoing myself as a reminder). Here's a url you can use as a "Learn more" link: https://support.mozilla.org/1/firefox/%VERSION%/%OS%/%LOCALE%/picture-in-picture

Flags: needinfo?(jsavage)

(In reply to Jeff Pfaller from comment #3)

Enable picture-in-picture video controls

and place the control in General > Browsing

I can do that, yes. We've been using the form "Picture-in-Picture" everywhere else - can I presume we'll use the same capitalization and hyphens?

Flags: needinfo?(jpfaller)

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up from PTO) from comment #5)

(In reply to Jeff Pfaller from comment #3)

Enable picture-in-picture video controls

and place the control in General > Browsing

I can do that, yes. We've been using the form "Picture-in-Picture" everywhere else - can I presume we'll use the same capitalization and hyphens?

I believe we'd like to do lowercase, since it's a feature, not a branded product.

Flags: needinfo?(jpfaller)

(In reply to Jeff Pfaller from comment #6)

I believe we'd like to do lowercase, since it's a feature, not a branded product.

Okay, understood, thanks.

The preference is only exposed if media.videocontrols.picture-in-picture.enabled is set
to true.

Here's a try build with the preference added: https://queue.taskcluster.net/v1/task/Ha96u69WQYCYPDscrhcWlw/runs/0/artifacts/public/build/target.zip

Is this satisfactory, Jeff?

Flags: needinfo?(jpfaller)

Hi, I'm not sure this is the right place to do this,

I searched for a preference to prevent the PiP window to hide the UI Buttons (Pause, Cross and the thing to put it back).

I could'nt find a reference to an already existing task about this.

However what preferences I think would improve UX :

  • Control the time to fade-out of the buttons in the UI with 0 = no fade-out;
  • make the buttons disappear when the mouse is out of the PiP window and appear when the mouse is IN : BOOL;

Currently the behaviour is that the whole UI only appear if the mouse is directly over one of the Buttons. I find myself searching blindly in the broad spot where the button I want to click is. It usually take one to two more seconds than it should.

Thanks! Dont hesitate to move this message anywhere else to better suit your task workflow I was'nt sure how to proceed on this.

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up from PTO) from comment #9)

I don't have a Windows machine, so I can't check this build. A screenshot would work?

Here's a try build with the preference added: https://queue.taskcluster.net/v1/task/Ha96u69WQYCYPDscrhcWlw/runs/0/artifacts/public/build/target.zip

Is this satisfactory, Jeff?

Flags: needinfo?(jpfaller)
Attached image Screenshot

Here's a screenshot of the new checkbox.

Flags: needinfo?(jpfaller)

(ni?ing for feedback on the screenshot in comment 12)

It looks good to me from a content perspective.

@emanuela - are we aligned on the order of this (putting PIP last). It feels right to me but I could also see maybe placing it above the "reco" controls

Flags: needinfo?(jsavage)
Flags: needinfo?(jpfaller)
Flags: needinfo?(emanuela)

Hey Jeff,

I'm also leaning towards adding it before Recommend extensions as you browse.

Thank you for asking!

Flags: needinfo?(emanuela)

Sounds good to me!

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7340ca11674b
Add a preference to control the Picture-in-Picture toggle to about:preferences. r=mstriemer,fluent-reviewers,flod
Status: NEW → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Assignee: nobody → mconley

Build ID 20190902191027
User Agent Mozilla/5.0 (Windows NT 10.0; rv:70.0) Gecko/20100101 Firefox/70.0

Verified as fixed on the latest Beta build (v70b3) and on the latest Nightly build.

Status: RESOLVED → VERIFIED
See Also: → 1581781
You need to log in before you can comment on or make changes to this bug.