Closed Bug 1573326 Opened 3 years ago Closed 3 years ago

Synced Tabs Sidebar buttons often lose their labels

Categories

(Firefox :: Sync, defect, P1)

70 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1576343
Tracking Status
firefox70 --- fixed

People

(Reporter: adavis, Assigned: markh)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

During a demo today, I observed that the button on the synced tabs sidebar was cut and unreadable.

See attached screenshots.

(note, I have not had time to replicate)

Assignee: nobody → markh
Priority: -- → P1

Hi Zibi,
The issue here is related to the interaction between fluent and the strange code used for the sidebar, and I'm hoping you can point me in the right direction.

In short, the sidebar uses templates - eg, consider this button. The first time this document is loaded, everything works correctly - that button has innerText, as the expected value as supplied by fluent.

However, quite regularly, the entire DOM tree is rebuilt via this code - when that code is run the second time, we see the newly inserted DOM nodes still have the correct data-l10n-id attribute from the template, but no longer have the innerText as supplied by fluent - as though fluent isn't noticing the DOM mutation.

Is there something we can call to ask fluent to update the DOM nodes after importing them from a template, or something else I'm missing which needs to be done here? Please let me know if you need any further information or help understanding the strange way this page is created.

Flags: needinfo?(gandalf)
Summary: Synced Tabs Sidebar Sign In Button Call to Action in Unreadable → Synced Tabs Sidebar buttons often lose their labels

The symptoms look similar to bug 1576343.

Can you provide an STR?

Flags: needinfo?(gandalf) → needinfo?(markh)

I'm actually having trouble providing an STR for when it does work, beyond:

  • Open the sidebar, ensure the "synced tabs" sidebar is shown.
  • Exit Firefox, run "./mach build faster", restart Firefox. The sidebar should restore as open, and the button should say "Sign in to Firefox" as expected. No idea why the "build" step is required here, but it does seem to be - without the build step, the sidebar restores without the button text.
  • Switch the sidebar to "bookmarks", then back to "synced tabs".
  • The button now has no text.

Mozregression tells me bug 1517880 is the culprit, specifically:

Bug 1517880 - Plug DOMLocalization and DocumentL10n into XULProtypeCache. r=smaug

Differential Revision: https://phabricator.services.mozilla.com/D38972

which given the description seems highly likely, so I'm marking this as a regression of that.

Flags: needinfo?(markh)
Keywords: regression
Regressed by: 1517880
See Also: → 1576343

I suspect the change in bug 1576343 (just landed on autoland) will fix this, but haven't had a chance to test.

Depends on: 1576343
See Also: 1576343

(In reply to :Gijs (he/him) from comment #5)

I suspect the change in bug 1576343 (just landed on autoland) will fix this, but haven't had a chance to test.

Surprisingly, it appears to not fix it :(

Zibi, can you please have a look?

No longer depends on: 1576343
Flags: needinfo?(gandalf)

hrmph - I'm not sure what I did wrong, but I tried again and :shrug:

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(gandalf)
Resolution: --- → DUPLICATE
Duplicate of bug: 1576343
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.