Closed Bug 1573362 Opened Last month Closed Last month

Update links to text label checks documentation to not include "<" and ">" characters.

Categories

(DevTools :: Accessibility Tools, task)

task
Not set

Tracking

(firefox69 fixed, firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: yzen, Assigned: yzen)

Details

Attachments

(2 files)

Janet from MDN suggested we avoid pointy brackets inside headers. The headings we'd like to change are these:

  • Use alt attribute to label {{htmlelement("area")}} elements that have the href attribute --> Use alt attributes to label area elements that have the href attribute (id="Use_alt_attribute_to_label_area_elements_that_have_the_href_attribute")

  • Documents must have a {{htmlelement("title")}} --> Documents must have a title (id="Documents_must_have_a_title")

  • {{htmlelement("fieldset")}} elements must be labeled --> Fieldset elements must be labeled (id="Fieldset_elements_must_be_labeled")

  • Use {{htmlelement("legend")}} element to label {{htmlelement("fieldset")}} elements --> Use a legend to label a fieldset (id="Use_a_legend_to_label_a_fieldset") //Sneaking in a copy-edit

  • {{htmlelement("frame")}} elements must be labeled --> Frame elements must be labeled (id="Frame_elements_must_be_labeled")

  • Use alt attribute to label {{mathmlelement("mglyph")}} elements --> Use alt attribute to label mglyph elements (id="Use_alt_attribute_to_label_mglyph_elements")

  • Use title attribute to describe {{htmlelement("iframe")}} content --> Use title attribute to describe iframe content (id="Use_title_attribute_to_describe_iframe_content")

  • Use label attribute to label {{htmlelement("optgroup")}} elements --> Use label attribute on optgroup elements (id="Use_label_attribute__for_optgroup_elements") //Another copy-edit

Copy edits on the accessibility panel side are probably too late for 69 so we would only want to request beta approval for url changes.

Ryan, do you know if it's still alright time wise to make these changes this week and get them approved for uplift?

Flags: needinfo?(ryanvm)
Flags: needinfo?(jswisher)

sorry only ment to cc

Flags: needinfo?(jswisher)

(In reply to Yura Zenevich [:yzen] from comment #0)

  • Use label attribute to label {{htmlelement("optgroup")}} elements --> Use label attribute on optgroup elements (id="Use_label_attribute__for_optgroup_elements") //Another copy-edit

There seems to be a subtle difference here between the text and the id. Should the id be "Use_label_attribute_on_optgroup_elements" ?

Flags: needinfo?(jswisher)

(In reply to Yura Zenevich [:yzen] from comment #2)

(In reply to Yura Zenevich [:yzen] from comment #0)

  • Use label attribute to label {{htmlelement("optgroup")}} elements --> Use label attribute on optgroup elements (id="Use_label_attribute__for_optgroup_elements") //Another copy-edit

There seems to be a subtle difference here between the text and the id. Should the id be "Use_label_attribute_on_optgroup_elements" ?

Yes, that's correct. (I typed the id's by hand because I haven't actually made the changes yet. The MDN editor automatically generates the id's based on the heading text.)

Flags: needinfo?(jswisher)

(In reply to Yura Zenevich [:yzen] from comment #0)

Ryan, do you know if it's still alright time wise to make these changes this week and get them approved for uplift?

My default position would be that Beta is string frozen at this point and any exceptions to that would need to go through the l10n team for approval.

Flags: needinfo?(ryanvm)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #6)

(In reply to Yura Zenevich [:yzen] from comment #0)

Ryan, do you know if it's still alright time wise to make these changes this week and get them approved for uplift?

My default position would be that Beta is string frozen at this point and any exceptions to that would need to go through the l10n team for approval.

This is not actually about user-visible strings in Firefox. This is about the ID's that are used to link to content on MDN.

Articles on MDN are HTML pages that contain section headings (h2, h3, etc.). These headings have id attributes that are automatically created by MDN's online editor tool, where the id value is the heading text with spaces replaced by underscores.

The Accessibility Inspector tool flags certain conditions and links to the corresponding heading in an article on MDN, via the heading id.

The string changes that Yura quoted above are changes I want to make to the headings in the MDN content, which would result in new ids, and therefore would require a code change in the Accessibility Inspector. They are not (necessarily) string changes in Firefox. (There would be a slight mismatch if the Firefox strings don't change, but I don't think it would be enough to cause user confusion.)

AFAICT, D41750 is touching files that will require localizers to have to deal with new strings. Someone from the l10n team is going to have to sign off on that being uplifted to Beta.

Yeah, to clarify I will only ask for uplift for one of the patches - https://phabricator.services.mozilla.com/D41749

Oh, then I don't see a problem with uplifting :)

Keywords: leave-open
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f896f31915a4
update links for the text label checks documentation. r=mtigley
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/43d96432677f
update a copy for some of the text label checks messages. r=mtigley,fluent-reviewers,flod

Comment on attachment 9085053 [details]
Bug 1573362 - update links for the text label checks documentation. r=mtigley

Beta/Release Uplift Approval Request

  • User impact if declined: MDN documentation links will be out of date.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just URL changes.
  • String changes made/needed: None
Attachment #9085053 - Flags: approval-mozilla-beta?
Keywords: leave-open
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Comment on attachment 9085053 [details]
Bug 1573362 - update links for the text label checks documentation. r=mtigley

Fix for out-of-date links on MDN. Approved for 69.0b15. Note that only this specific patch needs uplift.

Attachment #9085053 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.