[Mac] plugin.name and plugin.description not handled as in Netscape 4 (Adobe plugins missing a #STR resource)

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
17 years ago
7 years ago

People

(Reporter: jpmelko, Assigned: peterl-bugs)

Tracking

({platform-parity, testcase})

Trunk
Future
PowerPC
All
platform-parity, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA])

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1a+) Gecko/20020713
BuildID:    2002070303

for pdf viewer and svg viewer from adobe plugin.name is empty
the following script:
<script>
function VerifyPlugins()
     {var aindex
      for (aindex=0 ;
           aindex < navigator.plugins.length ;
            aindex++)
          {if (navigator.plugins[aindex].name.length == 0)
                    alert (navigator.plugins[aindex].description+" not found");
          }    
     }
VerifyPlugins();
</script>
shows alerts for adobe plugins

Reproducible: Always
Steps to Reproduce:
1.run the script in mozilla and Netscape 4
2.Show "about plugins" page in Netscape 4 and Mozilla
3.

Actual Results:  alerts for Adobe plugins in Mozilla
About-Plugins don't show the name in Mozilla

Expected Results:  No alerts, correct display of the name in show-plugins

After a look in the plugin resources of PDF viewer and Quicktime
i found that the Quicktime plugin has an
STR#,126 containing the description and the name (in this order)
the Adobe Plugins have an STR#,126 resource containing only the name.

I suspect Netscape 4 to return the second string of the resource for
theplugin.name, or the first if the second is not here
Mozilla seems to return always the second string.

I don't know who have to correct the bug: Mozilla or Adobe
I have Acrobat Reader 5.05

Comment 1

17 years ago
Created attachment 91240 [details]
HTML testcase

Comment 2

17 years ago
Browser, not engine ---> DOM Level 0 (or Plug-ins?)

I just have one Adobe plug-in running in Mozilla, and I don't see
the bug with it. When I try the testcase I attached above, I get
only this entry for Adobe Acrobat:

   PLUGIN NAME              PLUGIN DESCRIPTION
   Adobe AcrobatAdobe       Acrobat Plug-In Version 5.00 for Netscape


When I do Help > About Plug-ins, I get this:

   File name: nppdf32.dll
   Adobe Acrobat Plug-In Version 5.00 for Netscape


Jean-Pierre: can you run the above testcase, and Help > About Plug-ins,
and post the data you get for Adobe, as I have done above? Thanks -
Assignee: rogerl → jst
Component: JavaScript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 3

17 years ago
Small typo above; should have been:

---------------------------------------------------------------------------
When I try the testcase I attached above, I get only this entry
for Adobe Acrobat:

   PLUGIN NAME              PLUGIN DESCRIPTION
   Adobe Acrobat            Adobe Acrobat Plug-In Version 5.00 for Netscape


When I do Help > About Plug-ins, I get this:

   File name: nppdf32.dll
   Adobe Acrobat Plug-In Version 5.00 for Netscape

---------------------------------------------------------------------------
(Reporter)

Comment 4

17 years ago
File name: nppdf32.dll ???

Please try on a mac. The way that the name and description are stored is specific.

Not easy to do a copy and paste, i think i'll submit another bug. The tabs and
the returns are not copied to the clipboard.
So i'll create two attachement of the pages you asked. I have save them as "Web
complete". I think you'll see the things twice, because the Original JavaScript
is Saved and also the HTML Code generated on my machine. Look at the second part.
Do you think that it is another bug of the Save ?
(Reporter)

Comment 5

17 years ago
Created attachment 91242 [details]
About Plugins saved as "web page complete"
(Reporter)

Comment 6

17 years ago
Created attachment 91243 [details]
Test case result

Comment 7

17 years ago
Thank you for making the attachments. Note that both the about:plugins
attachment and the testcase attachment are dynamic HTML. Whoever clicks
on them will see his OWN plug-ins listed, and then Jean-Pierre's plug-ins
listed BELOW this. Here are the Acrobat plug-ins on Jean-Pierre's Mac:


------------------------  FROM ABOUT:PLUG-INS  ------------------------

File name: NPSVG3
Adobe SVG Viewer v3.0 for Macintosh

Mime Type                 Description     Suffixes     Enabled
image/svg+xml             SVG Document    svg,svgz       Yes
image/svg-xml             SVG Document    svg,svgz       Yes
image/vnd.adobe.svg+xml   SVG Document    svg,svgz       Yes


File name: PDFViewer
Adobe Acrobat Plug-in for Netscape, Version 5.00

Mime Type                 Description     Suffixes     Enabled
application/pdf                             pdf          Yes



------------------------  FROM THE TESTCASE  ------------------------

PLUG-IN NAME               PLUG-IN DESCRIPTION
                           Adobe SVG Viewer v3.0 for Macintosh 
                           Adobe Acrobat Plug-in for Netscape, Version 5.00 



Note the plug-in name is missing on these two, exactly as reported.
Confirming bug; although as pointed out above, is this a bug on our end
or on Adobe's end? 

cc'ing beppe@netscape.com, shrir@netscape.com: is this a known issue
on the Mac? Should this bug be in our Plug-ins component, DOM, or at Adobe?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

17 years ago
I agree

Remember that it's works correctly with Netscape 4.
If the name is missing, the name is set to the description and the Description
set to an empty string.

A work around in NS 4?, or it is in the specs ?

Comment 9

17 years ago
This is a normal plugin backwards compatibility bug. The problem is just as
described in the first comment (good report!). 

-->taking bug

We should do what 4.x does in this case. I'm seeing 4.x just use the filename if
the name is missing. Does that sound right?

As for the missing mime-type descriptions, I'm not seeing that problem. Is this
problem in Classic only? Could you attach the problematic SVG or PDF plugin
here? Thanks!
Assignee: jst → peterl
Component: DOM Level 0 → Plug-ins
Keywords: 4xp
OS: Mac System 9.x → All
Priority: -- → P3
QA Contact: desale → shrir
Whiteboard: [PL2:NA]
Target Milestone: --- → mozilla1.2beta
(Reporter)

Comment 10

17 years ago
Thanks, but it was not a good report.I was wrong in first report

NS 4 use the file name as plugin.name, and not the description

I attach PDF Viewer.
(Reporter)

Comment 11

17 years ago
Created attachment 91360 [details]
PDF Viewer

I send it as an hqx, because the bug is in the resource fork
STR#,126

Comment 12

17 years ago
we have a bug on this....I had seen this bug(pdf description field empty) last 
year or something. will have to find it.

Updated

17 years ago
Target Milestone: mozilla1.2beta → mozilla1.0.2
(Reporter)

Comment 13

17 years ago
found another thing
document.writeln("name: "+navigator.mimeTypes["application/pdf"].name);
document.writeln('<br>');
document.writeln("description: 
"+navigator.mimeTypes["application/pdf"].description);
document.writeln('<br>');
document.writeln("suffixes: "+navigator.mimeTypes["application/pdf"].suffixes);



With NS4:
name: undefined 
description: Portable Document Format 
suffixes: pdf 

With Mozilla:
name: undefined
description:
suffixes: pdf 

NS4 is not coherent with itself.
plugin.name gives the filename
navigator.mimeTypes["application/pdf"].name gives undefined

Mozilla is not coherent with itself.
plugin.description gives the correct description
navigator.mimeTypes["application/pdf"].description return an empty string


This description problem is only for "PDF viewer" plugin
The result are correct with NPSVG3 plugin

Theese two plugin have problem with plugin.name

(Reporter)

Comment 14

16 years ago
Created attachment 95396 [details]
Test Case for the two problems

Updated

16 years ago
Keywords: pp, testcase
Summary: plugin.name and plugin.description not handled as in Netscape 4 → [Mac] plugin.name and plugin.description not handled as in Netscape 4 (Adobe plugins missing a #STR resource)
Target Milestone: mozilla1.0.2 → mozilla1.2beta
(Reporter)

Comment 15

16 years ago
Is it normal that:
javascript:alert(navigator.mimeTypes["image/png"].enabledPlugin.name)

returns "Quicktime Plugin" With mozilla
and a "Has no property" error in NS4

png is handled internally and for me NS4 is right



Updated

16 years ago
Target Milestone: mozilla1.2beta → mozilla1.3alpha

Comment 16

16 years ago
future
Target Milestone: mozilla1.3alpha → Future
QA Contact: shrir → plugins

Comment 17

7 years ago
This isn't a problem any more, afaict, and we don't use resource files for plugin meta-data any more.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.