Closed Bug 1573431 Opened 1 year ago Closed 1 year ago

[Protections Panel] The "number of tracker" won't show if open the protections panel twice without moving the mouse

Categories

(Firefox :: Site Identity, task, P1)

task

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: timhuang, Assigned: timhuang)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(1 file)

STR:

  1. Open any page
  2. Open the protections panel by mouse clicking
  3. Close the panel by clicking the mouse without moving the mouse
  4. Then, open it again with the mouse clicking without moving the mouse

Actual:
The "number of tracker" doesn't show

Expect:
The "number of tracker" should show

We show the number of tracker if the data is up-to-date when opening the
panel.

Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5ea843b6282c
Fix the issue that the "number of trackers" won't show if reopening it without a mouse move. r=nhnt11
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+
QA Contact: ciprian.georgiu

I’ve reproduced this issue with Fx 70.0a1 (2019-08-13) on Windows 10 x64.
The issue is verified fixed with Fx 71.0a1 (2019-10-16) and Fx 70.0 across platforms (Windows 10 x64, macOS 10.14, Ubuntu 18.04 x64).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.