Closed Bug 1573516 Opened 4 months ago Closed 4 months ago

Implement a `QuantityMetricType`

Categories

(Data Platform and Tools :: Glean: SDK, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Dexter, Assigned: mdroettboom)

References

(Blocks 1 open bug)

Details

(Whiteboard: [telemetry:glean-rs:m8][geckoview])

Attachments

(4 files)

This new metric type is needed for reporting quantities (integer numbers) that have a magnitude and a unit.

The metric would only support the set operation and would be initially restricted to gecko_datapoint(s).

Example: gfx_display_width is a QuantityMetricType of 720 (magnitude) pixels (unit).

Blocks: 1566340
Priority: -- → P3
Whiteboard: [telemetry:glean-rs:m?][geckoview]
Duplicate of this bug: 1511361
Whiteboard: [telemetry:glean-rs:m?][geckoview] → [telemetry:glean-rs:m8][geckoview]
Assignee: nobody → mdroettboom
Attached file GitHub Pull Request
Attached file GitHub Pull Request
Attached file GitHub Pull Request
Attached file GitHub Pull Request
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.