Implicit declaration of function waitpid

RESOLVED DUPLICATE of bug 157378

Status

RESOLVED DUPLICATE of bug 157378
16 years ago
10 years ago

People

(Reporter: caillon, Assigned: caillon)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

gfx/src/xprint/xprintutil_printtofile.c:363
Implicit declaration of function `waitpid'

Comment 2

16 years ago
cailllon:
1. Thanks for the patch!
2. Are you sure that all Linux/Unix platforms have <sys/types.h> and
<sys/wait.h> (Solaris, AIX and Linux support the headers - but what about HP-UX,
FreeBSD, IRIX etc.) ?

Comment 3

16 years ago
I filed a new bug to slaughter more build warnings...

*** This bug has been marked as a duplicate of 157378 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.