Closed Bug 1573605 Opened 2 years ago Closed 2 years ago

[Protections Panel] Implement "None Detected" section to display tracking element categories not detected in the current page.

Categories

(Firefox :: Site Identity, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: nhnt11, Assigned: nhnt11)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(Whiteboard: [privacy-panel][skyline][test-isolation-backout])

Attachments

(2 files)

No description provided.
Summary: [Protections Panel] Implement "Not Found" section to display tracking element categories not detected in the current page. → [Protections Panel] Implement "None Detected" section to display tracking element categories not detected in the current page.
Attachment #9085732 - Attachment description: Bug 1573605 - Show undetected protections category items in a "Not Found" section, update UI to spec. r=johannh → Bug 1573605 - Show undetected protections category items in a "None Detected" section, update UI to spec. r=johannh
Attachment #9085732 - Attachment description: Bug 1573605 - Show undetected protections category items in a "None Detected" section, update UI to spec. r=johannh → Bug 1573605 - Show undetected protections category items in a "Not Found" section, update UI to spec. r=johannh
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/63d640d3d8b8
Show undetected protections category items in a "Not Found" section, update UI to spec. r=johannh
https://hg.mozilla.org/integration/autoland/rev/2bd2687949b5
More thoroughly test category item sections for various states. r=johannh
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/39c8d7cbd4d4
Show undetected protections category items in a "Not Found" section, update UI to spec. r=johannh
https://hg.mozilla.org/integration/autoland/rev/29bbdef3b6c2
More thoroughly test category item sections for various states. r=johannh
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Regressions: 1575477
Depends on: 1575491
Whiteboard: [privacy-panel][skyline] → [privacy-panel][skyline][test-isolation-backout]

Hi, can you help me understand what [test-isolation-backout] is about and how it affects this bug? Asking because it's part of a Skyline project and stability would be good since we're almost at merge day.

Flags: needinfo?(nhnt11) → needinfo?(bob)

nhnt11: https://wiki.mozilla.org/Auto-tools/Projects/Stockwell/Isolation is an experiment to determine if we can get clear signals as to the whether a bug is an intermittent or permanent failure. For the previous tests, I used bugs filed by sheriffs. Those were marked with [test isolation]. In the current phase I am looking at bugs whose patches were landed then backed out and am marking those bugs with [test-isolation-backout]. The marker is orthogonal to Skyline.

Flags: needinfo?(bob)
Whiteboard: [privacy-panel][skyline][test-isolation-backout] → [privacy-panel][skyline][test isolation backout]
Whiteboard: [privacy-panel][skyline][test isolation backout] → [privacy-panel][skyline][test-isolation-backout]
Flags: qe-verify+
QA Contact: ciprian.georgiu

This is verified fixed on latest Beta 70.0b14 under macOS 10.13, Ubuntu 18.04 x64 and Windows 10 x64.

Status: RESOLVED → VERIFIED
Regressions: 1586815
You need to log in before you can comment on or make changes to this bug.