Closed Bug 1573728 Opened 2 years ago Closed 2 years ago

Port |Bug 460146 - CSS3 border-image images should appear in Page Info -> Media| and |Bug 377364 - Page Info: Suppress the jumping in the bottom half of the Media tab| to SeaMonkey

Categories

(SeaMonkey :: Page Info, enhancement)

enhancement
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.67
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.1)

Attachments

(1 file, 1 obsolete file)

Port:

  • Bug 377364 - Page Info: Suppress the jumping in the bottom half of the Media tab. Improve consistency with the Element Properties Window
  • Bug 460146 - CSS3 border-image images should appear in Page Info -> Media
  • Part of Bug 713643 patch 5 - Unprefix the border-image-* properties and add a temporary alias for -moz-border-image
  • Part of Bug 792968 - Replace some regular expression string matches with String.startsWith and replace /^https?/ URI scheme tests with /^https?$/
Summary: Port |Bug 460146 - CSS3 border-image images should appear in Page Info -> Media| to SeaMonkey → Port |Bug 460146 - CSS3 border-image images should appear in Page Info -> Media| and |Bug 377364 - Page Info: Suppress the jumping in the bottom half of the Media tab| to SeaMonkey
Attached patch Update media handling (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Not all images displayed
Testing completed (on m-c, etc.): 2,53
Risk to taking this patch (and alternatives if risky):Low
String changes made by this patch:Yes

Attachment #9085327 - Flags: review?(frgrahl)
Attachment #9085327 - Flags: approval-comm-release?
Attachment #9085327 - Flags: approval-comm-esr60?
Comment on attachment 9085327 [details] [diff] [review]
Update media handling

> suite/browser/pageinfo/pageInfo.js
> +  else
> +    sizeText = gBundle.getString("mediaUnknownNotCached");

The else seems not to be hit. Image size is displayed as 0 KB (-1). 

Fx does get a cache entry at this place in 

In https://hg.mozilla.org/mozilla-central/annotate/409f3966645a651c8cb8d6d1e2f3fa995b69c739/browser/base/content/pageinfo/pageInfo.js#l775

So either this needs to be ported too in Bug 1573596 or the -1 needs to be taken into account.
Depends on: 1573596
Comment on attachment 9085327 [details] [diff] [review]
Update media handling

Everything else seems to be ok. f+ for the moment.
Attachment #9085327 - Flags: review?(frgrahl)
Attachment #9085327 - Flags: feedback+
Attachment #9085327 - Flags: approval-comm-release?
Attachment #9085327 - Flags: approval-comm-esr60?

This and update on bug 1573596 should have fixed the issue, hopefully

Attachment #9085327 - Attachment is obsolete: true
Attachment #9087121 - Flags: review?(frgrahl)
Attachment #9087121 - Flags: approval-comm-release?
Attachment #9087121 - Flags: approval-comm-esr60?

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/1d9b395d4a76
Port Bug 460146 "CSS3 border-image images should appear in Page Info -> Media" and Bug 377364 "Page Info: Suppress the jumping in the bottom half of the Media tab" to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Comment on attachment 9087121 [details] [diff] [review]
Update media handling v1.1

Forgot to set r/a before checkin because of the unrelated problem with bug 1573728. Correct version 1.1 was used for checkin.
Attachment #9087121 - Flags: review?(frgrahl)
Attachment #9087121 - Flags: review+
Attachment #9087121 - Flags: approval-comm-release?
Attachment #9087121 - Flags: approval-comm-release+
Attachment #9087121 - Flags: approval-comm-esr60?
Attachment #9087121 - Flags: approval-comm-esr60+
Whiteboard: SM2.53.1
You need to log in before you can comment on or make changes to this bug.