Closed Bug 1573758 Opened 1 year ago Closed 4 months ago

Consider dropping or extending tabs TTL

Categories

(Firefox :: Sync, defect, P3)

68 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 76
Tracking Status
firefox76 --- fixed

People

(Reporter: zioalex, Assigned: aarushivij, Mentored)

References

Details

(Keywords: good-first-bug)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

From device 1:
sync the tabs
From device 2:
Try to open the tabs from device 1.

I see my "Device 1" in the list of the Connected device.
Device 1 has been synced more that 2 months ago.

Actual results:

The device 1 is not listed in the Library --> Synced Tabs.

Expected results:

See the synced tabs and be able to open it.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Sync

Thanks for reporting, and sorry you are hitting this.

For historical reasons, tabs are only kept for 21 days. However, I can't see a great reason for this any more - we should extend it to a much larger value, while also ensuring that only devices which remain connected to the account have their tabs shown (which I believe is true today). This means the user can still kill old, stale devices via the FxAccounts device list.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: I cannot find my synced device in Library - Synced Tabs although my other device is connected. → Consider dropping or extending tabs TTL

Oh...:-O
yep would be great to have it for longer time.
I didn't find this documented anywhere. May be it should be.
Thanks to have clarified this.
I confirm that I see all the old connected devices...The bad things is that you cannot understand that in reality the cannot be recovered...

Mentor: markh
Keywords: good-first-bug
Priority: -- → P3

I've written a patch that extends the TTL for tabs to 366 days (1 leap year).

Feedback is welcome; although this is my first patch to Firefox ever, and I couldn't find any docs for people who want to contribute patches, so:

  • I haven't updated any automated tests (because I don't know where to find them),
  • it's probably in the wrong format (sorry; I come from the Drupal Open Source Community, so I'm used to their style of patches),
  • I've probably set the bug flags incorrectly (because I don't know what any of them mean), and,
  • it probably doesn't conform to coding standards (because I don't know what they are)

... so your patience with me would be appreciated.

I tried setting it to "review" so that someone else with more experience would look at it and tell me what to do next.

I would be very much willing to learn to do better if someone would be able to mentor me and walk me through the process of submitting patches! Thanks!

Attachment #9093464 - Flags: review+

Hey mparker, thanks for jumping in! You might find https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Introduction of interest - it explains how our code review process works. The patch itself looks fine, but will need to be a little different (eg, it will need to have a description etc - everything needed for it to land) - the doc above should explain that in some detail. When you upload it, flag me for review.

The r+ flag on an attachment means it has review - you can request review by setting the "?" flag, but as mentioned, now that we use phabricator there's no need to play with attachments nor the review flag directly. In the meantime I'll mark that attachment as obsolete.

Let me know if you have trouble with the phabricator instructions or the process in general and I'll do what I can to help you out (although not I'm in .au, so timezones may mean I take some time to respond)

Assignee: nobody → mparker17+mozilla
Status: NEW → ASSIGNED
Attachment #9093464 - Attachment is obsolete: true
Attachment #9093464 - Flags: review+

Hello, can I work on this?
Also to how many days, should it be extended to?
Thanks :)
Aarushi

Flags: needinfo?(markh)

Did you see comment 4? I've no problem with the ttl that chose.

Flags: needinfo?(markh)

Okay, I will submit the patch then :)

Attachment #9137592 - Attachment description: Bug 1573758 - COnsider dropping or extending tabs TTL. r=markh → Bug 1573758 - Consider dropping or extending tabs TTL. r=markh
Assignee: mparker17+mozilla → aarushivij
Attachment #9137592 - Attachment description: Bug 1573758 - Consider dropping or extending tabs TTL. r=markh → Bug 1573758 - Extend TTL for syncing tabs to 1 year. r=markh
Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bd051fd71e1c
Extend TTL for syncing tabs to 1 year. r=markh
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
See Also: → 1646795
You need to log in before you can comment on or make changes to this bug.