Closed Bug 1573759 Opened 2 years ago Closed 2 years ago

ASSERTION: Column set should be complete if the available block-size is unconstrained on 1566672.html

Categories

(Core :: Layout: Columns, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1575106

People

(Reporter: TYLin, Unassigned)

References

(Regression)

Details

My WIP patches in bug 1569701 can trigger an assertion

ASSERTION: Column set should be complete if the available block-size is unconstrained: 'aStatus.IsFullyComplete() || aReflowInput.AvailableBSize() != NS_UNCONSTRAINEDSIZE'

on the crashtest 1566672.html.

Should this block one of the bugs for shipping column span (to nightly or to release)?

Flags: needinfo?(aethanyc)

Yes. Since this soft assertion happens only on a particular crashtest, not on any reftests, let's have this block shipping column-span.

Flags: needinfo?(aethanyc)

This assertion is fixed by bug 1575106, and the assertion annotation is removed in bug 1575106 Part 4.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1575106
You need to log in before you can comment on or make changes to this bug.