Closed Bug 1573775 Opened 2 months ago Closed 2 months ago

Export a few MathML dir reftests to WPT

Categories

(Core :: MathML, task)

task
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: fredw, Assigned: fredw)

References

Details

Attachments

(1 file)

... and try to make them more reliable.

  • Tweak headers to add title and WPT meta tags.
  • Simplify text content and use the Ahem font to avoid "random" result.
  • Remove dir-11 since it has already been exported to
    mathml/relations/css-styling/dynamic-dir-1.html by @bkardell
  • Move dir-10 to mathml/presentation-markup/direction/direction-010.html
  • Move dir-09 to mathml/presentation-markup/direction/direction-009.html
    and add a .ini file for the corresponding failure expectation (bug 787215).
  • Move dir-08 to mathml/presentation-markup/direction/direction-008.html
    and add a .ini file for the corresponding failure expectation.
  • Move dir-07 to mathml/presentation-markup/direction/direction-007.html
  • Move dir-06 to mathml/presentation-markup/direction/direction-006.html
  • Remove duplicate test for RTL mtable@frame from dir-6a.html (already in
    dir-6) and do the general changes above. However, don't convert it for now
    as rowspacing is not in MathML Core (yet).

It seems the flakiness of dir-6a really is a real bug with the MathML rowspacing attribute, not an issue with fonts:

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/ZmIVFu0fSzKvToTQ09I-Lg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

How should I mark this expectation failure (using fuzzy seems incorrect)? Do I need to open a separate bug?

Flags: needinfo?(emilio)

Hmm, I am confused. The fuzzy annotation right now allows a max difference of up-to-135 in any color channel, only on OSX.

The reftest result you're showing is quite different though, it is showing full black/white differences, so indeed not fuzzy.

So I guess this is caused by that test change, right? It seems a vastly different kind of failure.

If you're sure that they should be the same, then yeah, annotating as failure, filing a bug and referencing it from the annotation sounds good. Though maybe we should just keep that test as-is for now and file the bug, to avoid losing test coverage for that?

Either way sounds fine though.

Flags: needinfo?(emilio)

(In reply to Emilio Cobos Álvarez (:emilio) from comment #3)

Hmm, I am confused. The fuzzy annotation right now allows a max difference of up-to-135 in any color channel, only on OSX.

The reftest result you're showing is quite different though, it is showing full black/white differences, so indeed not fuzzy.

So I guess this is caused by that test change, right? It seems a vastly different kind of failure.

If you're sure that they should be the same, then yeah, annotating as failure, filing a bug and referencing it from the annotation sounds good. Though maybe we should just keep that test as-is for now and file the bug, to avoid losing test coverage for that?

Either way sounds fine though.

Yes, the reftests should render the same. That's the case locally, although I sometimes also see some random failure with a big rowspacing difference on Linux. My guess is that the duplicate <mtable frame="solid"> test I removed was somewhat preventing this random failure to happen for some unknown reason. Let's handle this separately.

Assignee: nobody → fred.wang
Keywords: checkin-needed

I think this is ready to land, however I'm not sure how to test the old Windows XP failures with dir-7 and dir-10 with the try server. Do we actually still support this platform?

Flags: needinfo?(emilio)
Keywords: checkin-needed

No, we don't. We only run tests on win7/win10 IIRC.

Flags: needinfo?(emilio)
Keywords: checkin-needed

Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cd37bc4841c4
Export a few MathML dir reftests to WPT. r=emilio

Keywords: checkin-needed
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/18420 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.

Oops, direction-009-ref.html should have lquote and rquote inverted.

Flags: needinfo?(fred.wang) → needinfo?(aciure)
Flags: needinfo?(aciure)
Upstream PR was closed without merging

Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c928408c3402
Export a few MathML dir reftests to WPT. r=emilio

Keywords: checkin-needed
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.