Titlebar is empty while windowlist and tabtitle display correct title

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: relf, Assigned: mkaply)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Titlebar on the provided url is completely empty. There is no even regular
'Mozilla {Build ID: ...}' information.

Comment 1

16 years ago
Yes, the title bar is not being displayed. I think the reason for this is that,
there are a lot of   in the title. This might be the reason for the non
display of the title properly. This is a guess. I am not very sure.

Comment 2

16 years ago
WFM on 1.1a+ build 2002071008 on Mac OS 9. I can see a lot of Russian charcaters
on the left (displayed as question marks, but that's another bug), then a lot of
white space, and then an ellipsis (...) at the far right. If I open the window
full-screen (well, 800x600, since it's an old iBook), then I see the word
"cell..." (Latin charset), but the rest is still cut off. But the build ID is
completely gone ofcourse.

In Mac IE5, I can only see the first part of the title (the Russian part),
because it will always be cut off. The same in iCab.

Anyway it's a completely idiotic title, designed to spam the search-engines. The
word 'cellular', the first word after all those spaces, comes at position 136.
So this wouldn't normally be visible at all (I don't know why I still saw it in
my titlebar, unless those   were only 1 pixel-width each). 

On my Mac I can see at least part of the title, so this works for me. If 
there's another platform that doesn't display anything at all, then I can think
we'll have to fix that in the same way : cut off to a certain number.
(Reporter)

Comment 3

16 years ago
I'm using OS/2 build 2002071208. It doesn't show anything at all.

Is this bug related to bug #128396 ?
(Reporter)

Comment 4

16 years ago
BTW, in windowlist Mozilla shows correct title.

Comment 5

16 years ago
With Mozilla 1.1a+
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a+) Gecko/20020711
title bar is full of question marks (I suppose unprintable characters).
In other words title bar is not empty (Mozilla {Build ID: 2002071104} is gone.)

On Window list start and end of title bar text (BuilD ID) is visible, so 
Mozilla passes whole title bar to window manager and it is up to window manager
which part is shows. This window manager seems select text from middle of text.
( This is KDE.)

( Basically normal X11 resources are Latin/1 so it is not surprising that 
  russian letters do not show on tittle bar. I do not know protocol so much
  detail that is is possible to negotate for example COMPOUND_TEXT or    
  UTF8_STRING with window manager. Type STRING however must always be    
  ISO-8859-1.)

I think that this is quite separate issue on Windows, X11 and Mac.
(Reporter)

Updated

16 years ago
Summary: Titlebar is empty → Titlebar is empty while windowlist displays correct title
(Reporter)

Comment 6

16 years ago
Tabtitle also shows correct title.
OS -> OS/2
OS: All → OS/2
Summary: Titlebar is empty while windowlist displays correct title → Titlebar is empty while windowlist and tabtitle display correct title
<title>zvonki.RU - &#1080;&#1085;&#1092;&#1086;&#1088;&#1084;&#1072;&#1094;&#1080;&#1086;&#1085;&#1099;&#1081; &#1087;&#1086;&#1088;&#1090;&#1072;&#1083; &#1087;&#1086; &#1084;&#1086;&#1073;&#1080;&#1083;&#1100;&#1085;&#1086;&#1081;
&#1089;&#1074;&#1103;&#1079;&#1080;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;cellular,
mobile, russia, russian, networks, operators, GSM, AMPS, CDMA, DCS, NMT, UMTS,
billing, prepaid, 450, 800, 900, 1800, &#1089;&#1086;&#1090;&#1086;&#1074;&#1099;&#1081;, &#1089;&#1086;&#1090;&#1086;&#1074;&#1072;&#1103;, &#1089;&#1074;&#1103;&#1079;&#1100;, &#1084;&#1086;&#1073;&#1080;&#1083;&#1100;&#1085;&#1099;&#1081;,
&#1084;&#1086;&#1073;&#1080;&#1083;&#1100;&#1085;&#1072;&#1103;, &#1090;&#1077;&#1083;&#1077;&#1092;&#1086;&#1085;, &#1089;&#1077;&#1090;&#1100;, &#1089;&#1077;&#1090;&#1080;, &#1088;&#1086;&#1089;&#1089;&#1080;&#1103;, &#1057;&#1053;&#1043;, &#1073;&#1072;&#1079;&#1072;, &#1085;&#1086;&#1074;&#1086;&#1089;&#1090;&#1080;, &#1089;&#1086;&#1090;&#1086;&#1074;&#1072;&#1103; &#1089;&#1074;&#1103;&#1079;&#1100;,
&#1089;&#1086;&#1090;&#1086;&#1074;&#1099;&#1081; &#1090;&#1077;&#1083;&#1077;&#1092;&#1086;&#1085;, &#1089;&#1086;&#1090;&#1086;&#1074;&#1099;&#1081; &#1086;&#1087;&#1077;&#1088;&#1072;&#1090;&#1086;&#1088;, &#1089;&#1086;&#1090;&#1086;&#1074;&#1099;&#1077; &#1085;&#1086;&#1074;&#1086;&#1089;&#1090;&#1080;, &#1089;&#1086;&#1090;&#1086;&#1074;&#1072;&#1103; &#1072;&#1085;&#1072;&#1083;&#1080;&#1090;&#1080;&#1082;&#1072;, &#1084;&#1086;&#1073;&#1080;&#1083;&#1100;&#1085;&#1099;&#1081;
&#1090;&#1077;&#1083;&#1077;&#1092;&#1086;&#1085;, &#1084;&#1086;&#1073;&#1080;&#1083;&#1100;&#1085;&#1072;&#1103; &#1089;&#1074;&#1103;&#1079;&#1100;, &#1084;&#1086;&#1073;&#1080;&#1083;&#1100;&#1085;&#1099;&#1077; &#1085;&#1086;&#1074;&#1086;&#1089;&#1090;&#1080;, &#1084;&#1086;&#1073;&#1080;&#1083;&#1100;&#1085;&#1099;&#1081; &#1086;&#1087;&#1077;&#1088;&#1072;&#1090;&#1086;&#1088;, &#1088;&#1072;&#1076;&#1080;&#1086; &#1089;&#1074;&#1103;&#1079;&#1100;,
&#1088;&#1072;&#1076;&#1080;&#1086; &#1090;&#1077;&#1083;&#1077;&#1092;&#1086;&#1085;, &#1089;&#1086;&#1090;&#1086;&#1074;&#1072;&#1103; &#1072;&#1085;&#1072;&#1083;&#1080;&#1090;&#1080;&#1082;&#1072;, &#1072;&#1085;&#1072;&#1083;&#1080;&#1090;&#1080;&#1095;&#1077;&#1089;&#1082;&#1080;&#1077; &#1086;&#1073;&#1079;&#1086;&#1088;&#1099;, &#1072;&#1085;&#1072;&#1083;&#1080;&#1090;&#1080;&#1082;&#1072;, &#1072;&#1085;&#1072;&#1083;&#1080;&#1079;
&#1089;&#1086;&#1090;&#1086;&#1074;&#1086;&#1075;&#1086; &#1088;&#1099;&#1085;&#1082;&#1072;, &#1084;&#1072;&#1088;&#1082;&#1077;&#1090;&#1080;&#1085;&#1075;&#1086;&#1074;&#1099;&#1077; &#1080;&#1089;&#1089;&#1083;&#1077;&#1076;&#1086;&#1074;&#1072;&#1085;&#1080;&#1103;, &#1084;&#1072;&#1088;&#1082;&#1077;&#1090;&#1080;&#1085;&#1075;&#1086;&#1074;&#1099;&#1077; &#1080;&#1089;&#1089;&#1083;&#1077;&#1076;&#1086;&#1074;&#1072;&#1085;&#1080;&#1103; &#1089;&#1086;&#1090;&#1086;&#1074;&#1086;&#1075;&#1086;
&#1088;&#1099;&#1085;&#1082;&#1072;, &#1084;&#1072;&#1088;&#1082;&#1077;&#1090;&#1080;&#1085;&#1075; &#1074; &#1080;&#1085;&#1090;&#1077;&#1088;&#1085;&#1077;&#1090;, &#1089;&#1086;&#1090;&#1086;&#1074;&#1099;&#1081; &#1084;&#1072;&#1088;&#1082;&#1077;&#1090;&#1080;&#1085;&#1075;, &#1088;&#1099;&#1085;&#1086;&#1082; &#1089;&#1086;&#1090;&#1086;&#1074;&#1086;&#1081; &#1089;&#1074;&#1103;&#1079;&#1080;, &#1086;&#1087;&#1077;&#1088;&#1072;&#1090;&#1086;&#1088;&#1099;
GSM, &#1086;&#1087;&#1077;&#1088;&#1072;&#1090;&#1086;&#1088;&#1099; AMPS, &#1086;&#1087;&#1077;&#1088;&#1072;&#1090;&#1086;&#1088;&#1099; DCS, &#1086;&#1087;&#1077;&#1088;&#1072;&#1090;&#1086;&#1088;&#1099; UMTS, &#1086;&#1087;&#1077;&#1088;&#1072;&#1090;&#1086;&#1088;&#1099; CDMA, &#1086;&#1087;&#1077;&#1088;&#1072;&#1090;&#1086;&#1088;&#1099;
NMT, &#1086;&#1087;&#1077;&#1088;&#1072;&#1090;&#1086;&#1088;&#1099; UMTS, &#1089;&#1090;&#1072;&#1085;&#1076;&#1072;&#1088;&#1090;, &#1089;&#1090;&#1072;&#1085;&#1076;&#1072;&#1088;&#1090;&#1099; &#1089;&#1086;&#1090;&#1086;&#1074;&#1086;&#1081; &#1089;&#1074;&#1103;&#1079;&#1080;, &#1089;&#1090;&#1072;&#1085;&#1076;&#1072;&#1088;&#1090; GSM, &#1089;&#1090;&#1072;&#1085;&#1076;&#1072;&#1088;&#1090;
AMPS, &#1089;&#1090;&#1072;&#1085;&#1076;&#1072;&#1088;&#1090; CDMA, &#1089;&#1090;&#1072;&#1085;&#1076;&#1072;&#1088;&#1090; DCS, &#1089;&#1090;&#1072;&#1085;&#1076;&#1072;&#1088;&#1090; NMT, &#1089;&#1090;&#1072;&#1085;&#1076;&#1072;&#1088;&#1090; UMTS, &#1073;&#1080;&#1083;&#1083;&#1080;&#1085;&#1075; &#1074;
&#1089;&#1080;&#1089;&#1090;&#1077;&#1084;&#1072;&#1093; &#1089;&#1086;&#1090;&#1086;&#1074;&#1086;&#1081; &#1089;&#1074;&#1103;&#1079;&#1080;, &#1089;&#1080;&#1089;&#1090;&#1077;&#1084;&#1072;, &#1089;&#1080;&#1089;&#1090;&#1077;&#1084;&#1099;, &#1073;&#1080;&#1083;&#1083;&#1080;&#1085;&#1075;, &#1073;&#1080;&#1083;&#1083;&#1080;&#1085;&#1075;&#1086;&#1074;&#1099;&#1077; &#1089;&#1080;&#1089;&#1090;&#1077;&#1084;&#1099; &#1074; &#1089;&#1077;&#1090;&#1103;&#1093;
&#1089;&#1074;&#1103;&#1079;&#1080;, &#1089;&#1077;&#1090;&#1100;, &#1089;&#1077;&#1090;&#1080;, &#1090;&#1077;&#1083;&#1077;&#1082;&#1086;&#1084;&#1084;&#1091;&#1085;&#1080;&#1082;&#1072;&#1094;&#1080;&#1080;, &#1090;&#1077;&#1083;&#1077;&#1082;&#1086;&#1084;, &#1090;&#1077;&#1083;&#1077;&#1082;&#1086;&#1084;&#1084;&#1091;&#1085;&#1080;&#1082;&#1072;&#1094;&#1080;&#1086;&#1085;&#1085;&#1086;&#1077; &#1086;&#1073;&#1086;&#1088;&#1091;&#1076;&#1086;&#1074;&#1072;&#1085;&#1080;&#1077;,
&#1073;&#1072;&#1079;&#1072; &#1076;&#1072;&#1085;&#1085;&#1099;&#1093;, &#1073;&#1072;&#1079;&#1072; &#1076;&#1072;&#1085;&#1085;&#1099;&#1093; &#1089;&#1086;&#1090;&#1086;&#1074;&#1086;&#1075;&#1086; &#1088;&#1099;&#1085;&#1082;&#1072;, &#1084;&#1072;&#1088;&#1082;&#1077;&#1090;&#1080;&#1085;&#1075;&#1086;&#1074;&#1072;&#1103; &#1073;&#1072;&#1079;&#1072; &#1076;&#1072;&#1085;&#1085;&#1099;&#1093;
</title>

that's the (very long) title - see all the &nbsp; in there! Even on a 1600px
screen you won't go further then the "800".
Maybe OS/2 itself has a problem displaying Russian Characters in the titlebar?
(Assignee)

Comment 8

16 years ago
Are you on an English OS/2 or Russian Os/2?
(Reporter)

Comment 9

16 years ago
I'm using english OS/2 (there is no russian version of WSeB), but country is set
to Russia (country code 007) and system codepage 866.
(Assignee)

Comment 10

16 years ago
Confirming.

The issue is that PM is rejecting the titlebar string we are sending 
to it and hence displaying nothing.

Something is going wrong in the unicode conversion I believe
Assignee: Matti → mkaply
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 11

16 years ago
Created attachment 91376 [details] [diff] [review]
Fix for problem

This is actually an OS/2 bug at its core, but this is a workaround.

On OS/2, if you set a titlebar to > 512 chars, it displays nothing.

So we will limit to 256.
Comment on attachment 91376 [details] [diff] [review]
Fix for problem

r=pedemont,
sr=blizzard (platform specific code)
Attachment #91376 - Flags: superreview+
Attachment #91376 - Flags: review+

Comment 13

16 years ago
Comment on attachment 91376 [details] [diff] [review]
Fix for problem

a=asa (on behalf of drivers) for checkin to 1.1
Attachment #91376 - Flags: approval+
(Assignee)

Comment 14

16 years ago
Fix checked into trunk and branch (branch approval from chofmann via email)
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: fixed1.0.1
Resolution: --- → FIXED

Comment 15

16 years ago
asa or someone with OS/2 access:  can you verify this bug fix in 1.01 branch? 
When verified, pls replace fixed1.0.1 keyword with verified1.0.1.  Thanks.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.