Closed Bug 1573993 Opened 2 months ago Closed 2 months ago

Error: Module `devtools/server/main` is not found at resource://devtools/server/main.js base-loader.js:202:15

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 70.0

People

(Reporter: aceman, Assigned: jorgk)

References

(Regression)

Details

Attachments

(1 file, 1 obsolete file)

In current trunk on Linux I get this in the Error console:
Error: Module devtools/server/main is not found at resource://devtools/server/main.js base-loader.js:202:15

I'm not sure if it causes any problems.
We import "devtools/server/main" at https://searchfox.org/comm-central/rev/b0bfd7596c6d6f0ef580ce2c9cd680b2e6ca0bf1/mail/components/devtools/devtools-loader.js#37

But indeed it seems devtools/server/main was renamed in m-c in bug 1572390:
https://hg.mozilla.org/mozilla-central/rev/1de02e2036122b7f33f7ec301f5729d549ba6fa7

Attached patch 1573993-debugger-server.patch (obsolete) — Splinter Review
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #9085609 - Flags: review?(geoff)

Oops, only one dash for the commit message.

Attachment #9085609 - Attachment is obsolete: true
Attachment #9085609 - Flags: review?(geoff)
Attachment #9085610 - Flags: review?(geoff)
Comment on attachment 9085610 [details] [diff] [review]
1573993-debugger-server.patch

Review of attachment 9085610 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. I won't ship it as there's been no merge lately.
Attachment #9085610 - Flags: review?(geoff) → review+
Comment on attachment 9085610 [details] [diff] [review]
1573993-debugger-server.patch

Review of attachment 9085610 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, solves the error and fixes bug 1573988 :)
Attachment #9085610 - Flags: review+
Duplicate of this bug: 1573988

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/3fcb852ddff9
Port bug 1572390: Split main.js in debugger-server and debugger-server-connection. r=darktrojan DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0
You need to log in before you can comment on or make changes to this bug.