Closed Bug 1574048 Opened 3 years ago Closed 3 years ago

Remove FxAccounts internal/external/Object.freeze()/ weirdness

Categories

(Firefox :: Firefox Accounts, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox71 --- fixed

People

(Reporter: markh, Assigned: markh)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

This bug is to make FxAccounts.jsm saner and formalize the public API. Because this is a large refactor, we should try and avoid changing the API surface, and instead do that in followups.

Blocks: 1574051
Blocks: 1574052
Blocks: 1580398
Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/404c6f03dfc7
Remove FxAccounts internal/external/Object.freeze()/ weirdness. r=lina,rfkelly
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Regressions: 1582537
Regressions: 1582542
Regressions: 1585299
Regressions: 1585315
Regressions: 1587837
You need to log in before you can comment on or make changes to this bug.