clicking on buttons draws them out of position

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: warrensomebody, Assigned: troy)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I've noticed that if you click on one of the buttons at the top of the
travelocity page, e.g. "find/book a flight" the button will momentarily draw to
the left of where it should be.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 1

19 years ago
resolving as worksforme using today's opt bits on win98.  These are not
XPToolkit buttons anyway, so if you see this again, please reopen and assign to
Gecko.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
Component: XP Toolkit/Widgets → Layout
(Reporter)

Comment 2

19 years ago
Still happens for me with this morning's build. It doesn't happen every time
though. I wonder if it has some to do with the scrollbar appearing after the
page is laid out.
(Reporter)

Updated

19 years ago
Assignee: trudelle → rickg
Status: REOPENED → NEW
(Reporter)

Updated

19 years ago
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

19 years ago
Reassigning to Rickg (to reassign).

Comment 4

19 years ago
I'm seeing this again too, after coming back to the page. The page HTML content
seems to shift left when I go back to it, drawing a second time offset by
about one quarter inch. The images shift left when I click on them.

Comment 5

19 years ago
Rod -- can you diagnose the problem on this one?
Assignee: rickg → rods

Updated

19 years ago
Assignee: rods → troy

Comment 6

19 years ago
It is a layout problem/painting issue that doesn't have anything to do with img
css values. A good test is to start the viewer on NT, maximize the viewer, then
scroll down slowly until half the image "buttons" (which are really img src) are
scrolled out of view, then scroll back to the top. It appears that they have
been layed out correctly but it needs one additional paint to be called.

Test #2: maximize viewer, load travelcities, bring some other maximized app
forward (to force a repaint) then minimize it. It paints and everything is fine.

Assigning to troy because he was optimizing painting. (this could be a table
updating issue, but I am not sure)
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

19 years ago
*** Bug 13988 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
I no longer see any problems in today's builds as of the 1999110109 builds.
Marking VERIFIED
You need to log in before you can comment on or make changes to this bug.