Closed Bug 1574354 Opened 3 months ago Closed 3 months ago

As of version 68.0.1, Firefox always wraps lines, even from plain text/ascii files. It ignores the all of the wrap* settings found in the about:config page.

Categories

(Core :: Layout, defect)

68 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1565129

People

(Reporter: drsdgr, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Steps to verify:

Open Firefox version 68.0.1 or v68.0.2 and open a web log file which is a plain text/ascii file with long lines. You will see that Firefox always wraps the lines. This makes it difficult and confusing to read the document, where you naturally expect things to line up.

There are several wrap* related entries in about:config and Firefox ignores all of them. Firefox was fine until the recent change. This is a new feature/bug introduced in v68.0.1.

Actual results:

Text lines get wrapped around. A text line that should be one long line, gets wrapped into available scrollable width of the browser window.

Expected results:

The text should have displayed as single lines, where you would have to use the horizontal bar to see the rest of it.

This was the case until Firefox v68.0.1.

The only way to get the old behavior is to manually change the Page Style to No Style, each time and then change it back. Unfortunately, this gets tedious real quick.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Component: Untriaged → Layout
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1565129
You need to log in before you can comment on or make changes to this bug.