Closed Bug 1574433 Opened 11 months ago Closed 11 months ago

ImportError: cannot import name IndexSearch

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: farre, Unassigned)

References

(Blocks 1 open bug)

Details

Error running mach:

['artifact', 'toolchain', '--from-build', 'linux64-node']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

ImportError: cannot import name IndexSearch

File "/home/farre/src/gecko/work-1/python/mozbuild/mozbuild/artifact_commands.py", line 295, in artifact_toolchain
from taskgraph.optimize import IndexSearch
Error running mach:

['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '['/usr/bin/python2.7', u'/home/farre/src/gecko/work-1/mach', u'artifact', u'toolchain', u'--from-build', u'linux64-node']' returned non-zero exit status 1

File "/home/farre/src/gecko/work-1/python/mozboot/mozboot/mach_commands.py", line 44, in bootstrap
bootstrapper.bootstrap()
File "/home/farre/src/gecko/work-1/python/mozboot/mozboot/bootstrap.py", line 497, in bootstrap
checkout_root)
File "/home/farre/src/gecko/work-1/python/mozboot/mozboot/bootstrap.py", line 371, in maybe_install_private_packages_or_exit
self.instance.ensure_node_packages(state_dir, checkout_root)
File "/home/farre/src/gecko/work-1/python/mozboot/mozboot/linux_common.py", line 69, in ensure_node_packages
self.install_toolchain_artifact(state_dir, checkout_root, node.LINUX)
File "/home/farre/src/gecko/work-1/python/mozboot/mozboot/base.py", line 319, in install_toolchain_artifact
subprocess.check_call(cmd, cwd=state_dir)
File "/usr/lib64/python2.7/subprocess.py", line 190, in check_call
raise CalledProcessError(retcode, cmd)

Isn't IndexSearch defined in taskcluster/taskgraph/optimize.py in your tree?

Flags: needinfo?(afarre)

This was due to bug 1568277, which was backed out.

Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(afarre)
Resolution: --- → FIXED
Duplicate of this bug: 1574451
You need to log in before you can comment on or make changes to this bug.