descendants of 'visibility:hidden' can't be 'visibility:visible' in Mozilla

RESOLVED DUPLICATE of bug 157445

Status

()

RESOLVED DUPLICATE of bug 157445
17 years ago
17 years ago

People

(Reporter: tapio.markula, Assigned: attinasi)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
According to David Baron (<dbaron@fas.harvard.edu>) descendants of visibility:hidden can have visibility:visible. 

Mozilla 1.1a has bug in this matter.

Concering the CSS2 spec. the behavior of MS IE follows the stricly CSS2 spec. because the spec. ALLOWS that descendants of visibility:visible can have descencants, which have visibility:hidden. IF 'visibility' is inherited property, it is logical that descendants can have different values as their anchestors. BUT the new CSS3 spec. could however tell, that descendants of
visibility:hidden can have visibility:visible and at this mean it differs essential from 'display:none'.

This bug can be seen on the page:
http://www.nic.fi/~tapio1/Sielu/future.php3

there was something wrong in this page because a CSS-file was corrupted. I fixed this matter.
RELOAD the page if it looks bad.

In principle it should have nice dynamic menus like in most of my pages, but some CSS is missing.
If you HIDE the menu by using links on the right, ONE arrow should 
remain visible.

*** This bug has been marked as a duplicate of 157445 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.