Closed Bug 1574476 Opened 2 years ago Closed 2 years ago

Problem with Brazilian Summertime Timezone for 2019-2020

Categories

(Core :: JavaScript Engine, defect)

60 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1564330

People

(Reporter: ebasso, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.142 Safari/537.36

Steps to reproduce:

Please Update IANA timezone db to 2019b

According to the announcement at
https://mm.icann.org/pipermail/tz-announce/2019-July/000056.html

 Brazil no longer observes DST.

In JS console in should work like these:

new Date(Date.UTC(2019,7,20,9,59)).toLocaleString("en",{timezone: "America/Sao_Paulo", timeZoneName: "long"})

new Date(Date.UTC(2019,12,20,9,59)).toLocaleString("en",{timezone: "America/Sao_Paulo", timeZoneName: "long"})

tested 60.0.8esr

Actual results:

new Date(Date.UTC(2019,7,20,9,59)).toLocaleString("en",{timezone: "America/Sao_Paulo", timeZoneName: "long"})

"8/20/2019, 6:59:00 AM Brasilia Standard Time"

new Date(Date.UTC(2019,12,20,9,59)).toLocaleString("en",{timezone: "America/Sao_Paulo", timeZoneName: "long"})

"1/20/2020, 7:59:00 AM Brasilia Summer Time"

Expected results:

new Date(Date.UTC(2019,7,20,9,59)).toLocaleString("en",{timezone: "America/Sao_Paulo", timeZoneName: "long"})

"8/20/2019, 6:59:00 AM Brasilia Standard Time"

new Date(Date.UTC(2019,12,20,9,59)).toLocaleString("en",{timezone: "America/Sao_Paulo", timeZoneName: "long"})

"1/20/2020, 6:59:00 AM Brasilia Standard Time"

I have set this bug's component as (Core) JavaScript Engine because it seems to contain this timezone related code. Please set a more appropriate one if incorrect. Thank you.

Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1564330

Is it really correct, considering that the duplicate bug is already fixed and uplifted since a month ago?

Flags: needinfo?(andrebargull)

The tzdata 2019b release was right before the last Firefox release, so the changes didn't make it into Firefox 68 and 60.8. And therefore they've been in the tree for quite some time, but aren't yet visible in any Firefox releases. For example here's the result from Beta (69.0b14):

> new Date(Date.UTC(2019,12,20,9,59)).toLocaleString("en",{timeZone: "America/Sao_Paulo", timeZoneName: "long"})
"1/20/2020, 6:59:00 AM Brasilia Standard Time"

(Please note when trying to reproduce with the test cases from comment #0, that the correct property name is timeZone (with capital Z) and not timezone.)

Flags: needinfo?(andrebargull)
You need to log in before you can comment on or make changes to this bug.