Closed Bug 1574553 Opened 4 months ago Closed 2 months ago

Enable inline preview for all channels

Categories

(DevTools :: Debugger, task, P1)

task

Tracking

(firefox70 wontfix, firefox71+ fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox70 --- wontfix
firefox71 + fixed

People

(Reporter: Harald, Assigned: jlast)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When the first round of polish is done, we should open it up to all Nightly users to get more feedback, and barring any issues, let it ride the train.

Depends on: 1572882, 1573504, 1573507

Keeping an eye on this for beta/release 70.
Probably we should also add a release note; can you suggest wording for one?

Flags: needinfo?(hkirschner)

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1

Change of plans. We had a go/no-go checkin today and decided that the performance issue from bug 1578219 has not been addressed sufficiently to allow this going to release. Further fixes will be more invasive and risky.

Having it in wait in DevEdition 70 for one cycle is OK, to get more feedback from early adopters. Patches that we requested uplift for should still be considered to make the feature better for beta testers.

Probably we should also add a release note; can you suggest wording for one?

relnote-? is requested in https://bugzilla.mozilla.org/show_bug.cgi?id=1577926#c1

Flags: needinfo?(hkirschner)

OK, that seems very sensible. I will go ahead with the uplifts so that people can test in dev edition/beta.

Beta/Release Uplift Approval Request

  • User impact if declined: Inline preview will be released, which will slow down stepping in the debugger.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): we have tested the debugger with inline preview disabled.
  • String changes made/needed:
Assignee: nobody → jlaster
Attachment #9093154 - Flags: feedback?(dwalsh)
Attachment #9093154 - Flags: approval-mozilla-beta?

Oops, looks like i added the attachment to the wrong bug. I'll remove it here and add it to bug 1581645.

Comment on attachment 9093154 [details] [diff] [review]
beta-pref-v1.patch

># HG changeset patch
># User Jason Laster <jlaster@mozilla.com>
>Bug 1574553 - Limit inline preview to nightly and early beta. r=davidwalsh
>
>
>diff --git a/devtools/client/preferences/debugger.js b/devtools/client/preferences/debugger.js
>index 601c92723fcd..bc01d0d249af 100644
>--- a/devtools/client/preferences/debugger.js
>+++ b/devtools/client/preferences/debugger.js
>@@ -80,10 +80,15 @@ pref("devtools.debugger.features.autocomplete-expressions", false);
> pref("devtools.debugger.features.map-expression-bindings", true);
> pref("devtools.debugger.features.xhr-breakpoints", true);
> pref("devtools.debugger.features.original-blackbox", true);
> pref("devtools.debugger.features.event-listeners-breakpoints", true);
> pref("devtools.debugger.features.dom-mutation-breakpoints", true);
> pref("devtools.debugger.features.log-points", true);
> pref("devtools.debugger.features.overlay-step-buttons", false);
> pref("devtools.debugger.features.overlay-step-buttons", true);
>-pref("devtools.debugger.features.inline-preview", true);
> pref("devtools.debugger.features.watchpoints", false);
>+
>+#ifdef EARLY_BETA_OR_EARLIER
>+  pref("devtools.debugger.features.inline-preview", true);
>+#else
>+  pref("devtools.debugger.features.inline-preview", false);
>+#endif
Attachment #9093154 - Flags: feedback?(dwalsh)
Attachment #9093154 - Flags: approval-mozilla-beta?

Backed in beta for landing with the wrong bug number. Relanded the patch with the correct bug number.
https://hg.mozilla.org/releases/mozilla-beta/rev/d3992ddf68c7168b579cac1a63685f5a496ddf71

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.