Closed Bug 1574819 Opened 3 months ago Closed 3 months ago

Bookmarks Menu Button popup doesn't auto-open on drag enter

Categories

(Toolkit :: XUL Widgets, defect)

69 Branch
Desktop
Unspecified
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- wontfix
firefox70 --- verified

People

(Reporter: jscher2000, Assigned: surkov)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

In Developer Edition, drag from the site identity area or drag a link from the page and hover the Bookmarks Menu Button.

Actual results:

The #BMB_bookmarksPopup doesn't auto-open. Reported on SUMO at https://support.mozilla.org/questions/1266993

Expected results:

The #BMB_bookmarksPopup should auto-open.

In case helpful, button:

<toolbarbutton id="bookmarks-menu-button" 
ondragenter="PlacesMenuDNDHandler.onDragEnter(event);" 
ondragover="PlacesMenuDNDHandler.onDragOver(event);" 
ondragleave="PlacesMenuDNDHandler.onDragLeave(event);" 
ondrop="PlacesMenuDNDHandler.onDrop(event);" 
oncommand="BookmarkingUI.onCommand(event);" 
removable="true" cui-areatype="toolbar">

mozregression result:

2019-08-18T17:48:59: INFO : application_vendor: Mozilla
2019-08-18T17:48:59: INFO : application_version: 69.0a1
2019-08-18T17:48:59: INFO : platform_buildid: 20190522232535
2019-08-18T17:48:59: INFO : platform_changeset: c8e9b6a81194dff2d37b4f67d23a419fd4587e49
2019-08-18T17:48:59: INFO : platform_repository: https://hg.mozilla.org/integration/mozilla-inbound
2019-08-18T17:48:59: INFO : platform_version: 69.0a1
2019-08-18T17:49:36: INFO : Narrowed inbound regression window from [f287bb6c, d4a9b4dd] (3 builds) to [f287bb6c, c8e9b6a8] (2 builds) (~1 steps left)
2019-08-18T17:49:36: DEBUG : Starting merge handling...
2019-08-18T17:49:36: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=c8e9b6a81194dff2d37b4f67d23a419fd4587e49&full=1
2019-08-18T17:49:37: DEBUG : Found commit message:
Bug 1519577 Convert toolbarbutton to a custom element r=surkov

Differential Revision: https://phabricator.services.mozilla.com/D31941

Potentially this is a similar issue/fix to folders on the Bookmarks Toolbar not opening on hover (bug 1555496). But I don't understand this code, so...

Andrew, Your bunch of patch seems to cause the regression. Can you please look into this?

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → XUL Widgets
Ever confirmed: true
Flags: needinfo?(andrew.swan)
Keywords: regression
Product: Firefox → Toolkit
Regressed by: 1519577
Hardware: Unspecified → Desktop
Duplicate of this bug: 1574820

Andrew is no longer with Mozilla. Alexander, can you maybe take a look at this as the reviewer of the regressing patch? Otherwise, feel free to redirect as necessary. Thanks!

Flags: needinfo?(andrew.swan) → needinfo?(surkov.alexander)
Assignee: nobody → surkov.alexander
Flags: needinfo?(surkov.alexander)

(In reply to jscher2000 from comment #0)

Potentially this is a similar issue/fix to folders on the Bookmarks Toolbar not opening on hover (bug 1555496). But I don't understand this code, so...

Indeed it was similar issue. If you are comfortable with JS code, then little of debugging usually helps for issues like this one, for sure as long as you have entry point, which is PlacesMenuDNDHandler.onDragEnter in this case as you mentioned above.

Pushed by asurkov@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/32bc8be194ac
Bookmarks Menu Button popup doesn't auto-open on drag enter r=mak
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Duplicate of this bug: 1579674
Flags: qe-verify+
Duplicate of this bug: 1580163
Duplicate of this bug: 1581936

Reproduced the initial issue on Firefox 69.0.1.
Verified fixed on Windows 7 x64, Ubuntu 18.04 x64 and macOS 10.14 using Firefox 70 Beta 9 (20190923154733).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.