Closed Bug 1574951 Opened 4 months ago Closed 4 months ago

Webextension is not installed via GPO

Categories

(Firefox :: Enterprise Policies, defect)

68 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1571120

People

(Reporter: konrad, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36

Steps to reproduce:

  1. Install Firefox 68.0 on fresh copy of Windows (no Mozilla folders in users profile directory).
  2. Install the webextension via GPO (after that there is a value in windows registry with the extension's path in key HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\Extensions\Install). Out extension has id=uplook_network_filter_1.7@aplusc-systems.com.
  3. Start the Firefox.

Actual results:

The browser doesn't load the extension.

Expected results:

The browser should load the extension (FF 67.0.4 loads it smoothly).

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Enterprise Policies

Are you using a local path or a remote path?

It's a local path: C:\Program Files (x86)\A plus C Systems\uplook\Agent\uplook_network_filter-1.7-fx.xpi

Can you try:

file://C:/Program Files (x86)/A plus C Systems/uplook/Agent/uplook_network_filter-1.7-fx.xpi

We have a bug where legacy paths aren't working. There should be a patch in soon

Now the extension is loaded with no problem.

Can you estimate in what version of Firefox the bugfix will be available (or when)?

Could you provide a link to that bug so I can get more information?

And last question: Does Mozilla recommend to use the remote paths over local? Or it just doesn't matter?

Here's the bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=1571120

I'm hoping to have it fixed in Firefox 69, ESR 68.1

We definitely don't have a preference of remote over local. Both should work fine.

We are going to recommend the file:// URL format in the future. We have a new extension policy we'll be rolling out that requires URLS (not local paths).

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1571120
You need to log in before you can comment on or make changes to this bug.